EOS goes blank when virtio has 3D acceleration enabled

This problem was mainly pointed out by @ricklinux while testing virt-manager with virtio with 3D acceleration. I tested it out and it seems to happen with eos live and installed in the VM.

The issue is this when virt-manager has graphical settings set like below.

Display Spice.

Video.

We can load into eos graphical environment. This happens with live environment and with an installed system. With the installed version (used the offline install) everything works until lightdm. After logging in everything goes blank only the correct cursor can be seen.

Then I tested the same settings with Arco Linux which worked.

We can drop into ttl and work there. I decided to post it here so someone with more knowledge can shed some light on this matter and if this is eos issue then probably you guys can fix it. I’ll try another environment other than XFCE to see if that’s loves it.

I just installed eos BSPWM edition and it worked with 34 enabled. I’m testing KDE as we speak to see if this is got to do with the compositor. Because BSPWM has picom.

If KDE works I will check with Arco Linux XFCE. To see if it’s caused by XFCE generally or not.

eos KDE is working virtio 3D enabled. So it seems it’s XFCE. What would cause blank scree?

If you go into a tty you can make lightdm come on but if you log back into live system it goes black again.

1 Like

I can confirm it’s XFCE. I just installed Acro Linux with XFCE and it did the same blank screen.

1 Like

It’s possibly the xfwm compositor… :thinking:

If i uncheck 3D i can use virtio. So i probably don’t need to set the splice settings then.

Edit: But the install doesn’t proceed. It’s stuck here!

Edit: I can run virtio and not touch 3D setting box or splice open gl and worked.

Yes, the problem occurs with XFCE. So the workaround is for now if DE = XFCE {use QXL or vitrio no 3D} else {can use vitrio with 3D}

1 Like

Yes, it is the default compositor. I just tried loading eos XFCE after disabling the compositor. And it worked.


I’m going to install another compton or picom and try again.

EDIT: Tried it with Picom and it worked. Also, Picom seems to be better than the default compositor for XFCE.

What are you changing it on? After it’s installed?

Yes, after install. I’ll write a how-to soon.

You marked your confirmation post that xfwm’s compositor has an issue as the solution? I mean, I guess so, …

Might be nice to report this as a bug somewhere so it can be fixed rather than documenting a workaround. :man_shrugging:

Yes, due to the workaround

It’s not an unknown issue with xfwm.

Bug report at qemu: https://bugs.launchpad.net/qemu/+bug/1898490

It’s an upstream issue that would eventually get fixed. Until then people would benefit from a workaround so what would be the harm of documenting one.

Whether it’s a QEMU issue or an xfwm issue, the “correct” upstream has to know about it:

You’re perpetuating the existence of an error rather than working towards a fix. The bug report is itself “documenting the issue”.

People who need to know knows, and you don’t have to tell me what I need to or not. I can decide for myself if I want to report or not.

I wanted to find what was happening with virt and Xfce I did. Wanted to find a way around I did. Wanted to let someone else who could benefit from it I’m going to do.

Fixing the issue will be done in time because they think this is not a major bug. Me posting the same issue won’t be going to force anything. Now you even know the issue so do some testing and report the issue if your so hung up on me not reporting.

The thread was opened by me to inform others it was not basically asking for a solution. Then I myself found a workaround that was enough for me to close the thread.

I won’t be creating any bug reports and that is where I stand. If you want go ahead and do it yourself without telling me what to do. Have a nivce day, I’m done talking about this.

No, but it would tell them that there is a bug. Did you read the text I quoted?

OK, that’s your choice. Of course, you’re the one who found the bug and can replicate the bug so you’re in an ideal place to report the bug, but if you’d prefer to do something completely different then you’re free to do so.

This sort of attitude is counterproductive.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.