EOS Gemini-2024.04.20.iso -- not working?


(please excuse me for my part in having these multiple issues. I do appreciate the assistance and attention given.)

After burning the new EOS-Gemini-2024.05.31-x86_64ISO, I now cannot boot from the ISO usb.

Multiple gremlins seem to be affecting my forward progress towards reinstalling EOS.

Perhaps we should let this particular chat topic close – I will try new ideas as they come to me and will later reopen this chat topic if I am not successful.

thank you, Gary

could be an issue with the usb stick too ?
It is really rare for calamares to simply hardcrash in that way… plus your issues with partition managers.
this looks a lot like corruptions.

burned the new ISO using a different USB stick…

the thought of corruption has occurred to me – just not certain of what.
This computer is operating with all the same hardware from a different OS and a different partition.

An attempt to install arch failed (selecting partition-7 as root.)

Will try to install arch using a different partition as root.

Please note that calamares may not work well if you go back and forth in its menus. So you need to start “fresh” and reboot before trying a new install.

1 Like

this is what it would show without any usable drives.
Log would tell it too.
In most cases, calamares is crashing or behaving strange if there are corruptions to the ISO file.

sudo parted -l  :heavy_check_mark:  4s 
Model: Micron MTFDKBA512TFH (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 274MB 273MB fat32 EFI system partition boot, hidden, esp, no_automount
2 274MB 290MB 16.8MB Microsoft reserved partition msftres
3 290MB 90.0GB 89.7GB ntfs Basic data partition msftdata
5 90.0GB 134GB 43.7GB ext4 manj root
6 134GB 229GB 94.8GB ext4 manj /home
10 229GB 230GB 1078MB fat32 EFI system part boot, hidden, esp, no_automount
7 230GB 357GB 127GB ext4
8 357GB 365GB 8179MB linux-swap(v1) swap
9 365GB 510GB 145GB ext4 end /home
4 510GB 512GB 2097MB ntfs Basic data partition hidden, diag, no_automount

(I created a second boot partition at 10 in anticipation of starting an install with a larger boot partition.)

Partition 10 should be large enough for ESP, but partition 1 seems not.




Nothing in the logs indicates why calamares fails to open?

Tried many distros without install success.
Calamares does seem to have an issue.

openSUSE Leap did install – seems a little wonky, however

Perhaps the calmares issue is unique to my hardware? firmware? drivers?``

The log shows insufficient space for all partitions.
Are you trying automatic partitioning? Looks like manual partition settings in calamares is needed.

Please show the output of

lsblk -fm

only a bet in the dark… but can you show output of xrandr ?
xrandr | eos-sendlog or check the settings for display to see if it shows more than one display.
Could be that calamares does start but is opening on non-existing second display.

manuel, I am aware of several partitions being small – I “borrowed” from a /home partition to save some loaded data and provide myself an empty partition for a new distro install.

joekamprad, I have successfully installed NixOS and it uses calamares. I had to select the nomodeset option – however once NixOS booted, there is a system issue that still needs a fix.

I used gparted to expand my ESP partition to 900 mb – moving the Windows partition over.

I seem to be on a path to save access to Windows OS and have two operating Linux partitions on my too small installed drive.

As it stands now, I have both a working Manjaro and Windows OS partition, I have installed openSUSE several times, but I am investigating use of NixOS in its place. I have enjoyed endeavourOS for several years, but also have experienced some time-consuming regressions due to package updates.

postscript: I am wondering if use of immutable linux distros will increase in popularity. The potential for a more stable OS system requiring less updates seems appealing. I welcome opposing views from more experienced linux users.

After many distro installation attempts, I decided to try another EndeavourOS reinstall one more time.

IT WORKED, calamares opened up !

my KDE plasma is still not 100%

nice to see you are fighting still! :enos:

install went fine or does not finish to install kde?
You may hit wayland default now issue only. Logout and change session type to X11 could resolve.