EOS does not boot: "no such cryptodisk found."

Hey guys,

I have just finished running the latest EOS installer (I updated before running the installer) and not a good start…

I chose to encrypt the partition (with LUKS) and also chose Swap (no hibernation). After being asked to type my password, I get the following error:

error: access denied.
error: no such cryptodisk found.
error: disk 'cryptouuid/94321842198ufds9874218fud8sa97432fdsa" not found.'
Entering rescue mode . . .
grub rescue>

I chose i3wm and base-devel. Any suggestions?

Sometimes it works, sometimes it doesn’t… And when it works, it takes forever to accept the password… Really bad experience so far.

Any pointers?

updated the welcome app or the live system?

On my testing laptops I do get the same problems when installing EOS with calamares and the complete encryption. Only every second boot the password is accepted, even if I am using a very simple one.

It needs some time, that the password is accepted and then the grub menu starts whichs needs another 5 seconds to finish. Something you can change in /etc/default/grub and then run the reconfigure of grub.
I do not have a solution for your problem.

I don’t understand the question. I booted EOS, and clicked on the “Update this app!” or something like that, before doing “Install system” or whatever.

If you ever find a way to fix this, please let me know! It’s really annoying.

This is the first time we got someone with this issue.
Would need to get boot log and install log to be able to investigate.

on installed system install log is saved here:
/var/log/Calamares.log
cat /var/log/Calamares.log | curl -F 'f:1=<-' ix.io

@joekamprad
Installed on v-box erase disc with swap using latest iso full encryption. I tried twice last night and got failures on both. Booted to grub rescue error with grub on both. One without updating and one with updating the welcome app. This one i installed in v-box this morning and it worked fine.

Install Log
http://ix.io/2iW7

Although it installed it is not working well. Won’t open a terminal. :disappointed:

http://ix.io/2iWl

can i get the /etc/mkinitcpio.conf ?

"grub-install", "--target=i386-pc", "--recheck", "--force", "/dev/sda"
Installing for i386-pc platform.
Installation finished. No error reported.
"grub-mkconfig", "-o", "/boot/grub/grub.cfg"
Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
done

May be worth checking if your disk UUID is the same that on /etc/default/grub
Need to boot the iso and run sudo blkid

Also check if you have the line GRUB_ENABLE_CRYPTODISK=y at /etc/default/grub

Wait what? Why is “–target=i386-pc”?

–target=x86_64-efi is only for uefi SYSTEMS // BIOS (legacy) systems needs –target=i386-pc

"grub-install", "--target=i386-pc", "--recheck", "--force", "/dev/sda"

is legacy BIOS it installs grub on MBR of the disk…

1 Like

i do see this here too seems an issue with terminator terminal…

[joekamprad@eos-2020.04.19 >~]$ terminator
Traceback (most recent call last):
  File "/usr/bin/terminator", line 48, in <module>
    import terminatorlib.optionparse
  File "/usr/lib/python3.8/site-packages/terminatorlib/optionparse.py", line 24, in <module>
    from . import config
  File "/usr/lib/python3.8/site-packages/terminatorlib/config.py", line 75, in <module>
    from configobj import ConfigObj, flatten_errors
ModuleNotFoundError: No module named 'configobj'

aha:
python-configobj is missing …
https://bugs.archlinux.org/task/66329?project=5&string=terminator

4 Likes

I thought something is wrong because things just didn’t seem to work very well. I went back to Cinnamon now for a while. I gave up on trying the encryption also as i had the same issue trying to install it on v-box. It is strange to me because before when testing with the ISO’s before the latest one it always worked for me.

What are the implications of that?

this is only for grub itself…system will boot x86_64 anyway :wink:

I have seen this error too and it happened when i have not created first separate /boot patition. I created btrfs encrypted single partition marked as boot and root, but seen that error. Though it worked after i have followed suggestion to first create /boot partition with boot flag and ext2 filesystem. Tick encryption, then create second partition (in my case btrfs filesystem) with mountpoint “/” and encryption also ticked. Hope it help someone.
PS: developers should make the GUI installer more friendly so one knows how to make full encrypted disk with custom filesystem.