enOS on MacbookPro3,1 no xorg

Hi, my first post, be nice to me.
I have 2 x macOS, Fedora, artix, antix on my old MBP3,1 which has NVIDIA GeForce 8600M GT graphics.
I tried online install and X wouldn’t start so I tried with offline and that’s the same.
I’ve tried to RTFM, looked at Arch Nvidia, unwisely got distracted (ADHD) and followed instructions from blogs.
I thought today to examine my artix install to see how it differs from the enOS one, but today artix wouldn’t boot to a GUI either.
I’m too old to want to learn about the intricate details of nvidia and nouveau, I’d like to get this early hurdle jumped so I can get on with learning more (to me) interesting stuff.
Fedora/Gnome and Antix/rox-iceWM work just fine, and artix did until today after some initial driver install stuff.
I don’t care too much about 3-D acceleration and hi-def YT playback on this old clunker, but if there is anyone out there with a bit of compassion for a tech-y guy wih learning disabilities who could tell me, hey this is the way, I’d be grateful, plus you’d get a front seat in heaven. Cheers and Dank je wel to al the cloggies out there.

EndeavourOS has 2 boot options: Closed source drivers allowed (aka Nvidia) and open source only. Did you try both?
EDIT: Your card’s generation (Tesla) is currently unsupported and cannot run Xorg with propriearty drivers. At least on Arch Linux and derivates.

Thanks for the reply. To be honest I’ve done stuff without properly taking note of what and in what order. Yesterday I installed nvidia-340xx-dkms to no avail. Today I copied the grub options off the LiveUSB and pasted them into my enOS install grub, to no avail.
You can see I’ve not been very systematic about it. Right now I’m wondering if I should try nouveau again or downgrade xorg-server to 1.19 or 1.20 to get it to work with the nvidia driver. I don’t have much understanding or experience with kms, drivers etc. Thanks for your help.