EnOS Calamares Community Editions won't install

Newbie here!
Tried to install as a liveuser.
I used Rufus, the version is the latest one with EndeavourOS_Cassini_Nova-03-2023_R1.iso.
I selected the community version “Openbox Edition”, I did try Worm Edition too, did not work either.


1 Like

From the install log:

2023-05-01 - 14:11:24 [6]: [PYTHON JOB]: “error: target not found: ttf-nerd-fonts-symbols-2048-em”
2023-05-01 - 14:11:24 [6]: [PYTHON JOB]: “error: target not found: xcursor-neutral”

In the package selection section of the installer, uncheck the box for these two packages and try installing again.


Alternatively, before launching the installer, you could edit the file:


and remove xcursor-neutral and replace ttf-nerd-fonts-symbols-2048-em with ttf-nerd-fonts-symbols.


The problem is xcursor-neutral is no longer in the ArchLinux main repositories but the the Community Editions (except for Sway) still call for xcursor-neutral during Calamares install.

xcursor-neutral is available in the AUR but it is listed as “orphoned”

I will fire up Cassini Nova and see if a person can delete xcursor-neutral before starting the install.

More to come.


The problem has proved to be that


is no longer in the Archlinux Repos. It looks like xcursor-neutral was a dependency, and is also no longer in the repos.

Since you supplied the installation log, here is the section that had the information “told the story”.

2023-05-01 - 14:11:22 [6]:     .. Running ("pacman", "-S", "--noconfirm", "--noprogressbar", "--needed", "--disable-download-timeout", "libwnck3", "mesa-utils", "xf86-input-libinput", "xorg-xdpyinfo", "xorg-server", "xorg-xinit", "xorg-xinput", "xorg-xkill", "xorg-xrandr", "xf86-video-amdgpu", "xf86-video-ati", "b43-fwcutter", "broadcom-wl-dkms", "dhclient", "dnsmasq", "dnsutils", "ethtool", "iwd", "modemmanager", "networkmanager", "networkmanager-openconnect", "networkmanager-openvpn", "nss-mdns", "usb_modeswitch", "wpa_supplicant", "xl2tpd", "firewalld", "python-pyqt5", "python-capng", "downgrade", "pacman-contrib", "pkgfile", "rebuild-detector", "reflector", "yay", "accountsservice", "bash-completion", "bluez", "bluez-utils", "ffmpegthumbnailer", "gst-libav", "gst-plugin-pipewire", "gst-plugins-bad", "gst-plugins-ugly", "libdvdcss", "libgsf", "libopenraw", "mlocate", "poppler-glib", "xdg-user-dirs", "xdg-utils", "efitools", "haveged", "nfs-utils", "nilfs-utils", "ntp", "smartmontools", "unrar", "unzip", "xz", "adobe-source-han-sans-cn-fonts", "adobe-source-han-sans-jp-fonts", "adobe-source-han-sans-kr-fonts", "cantarell-fonts", "freetype2", "noto-fonts", "ttf-bitstream-vera", "ttf-dejavu", "ttf-liberation", "ttf-opensans", "alsa-firmware", "alsa-plugins", "alsa-utils", "pavucontrol", "pipewire-pulse", "wireplumber", "pipewire-alsa", "pipewire-jack", "rtkit", "dmidecode", "dmraid", "hdparm", "hwdetect", "lsscsi", "mtools", "sg3_utils", "sof-firmware", "power-profiles-daemon", "upower", "endeavouros-theming", "eos-apps-info", "eos-log-tool", "eos-packagelist", "eos-quickstart", "eos-rankmirrors", "eos-update-notifier", "reflector-simple", "welcome", "duf", "findutils", "fsarchiver", "git", "glances", "hwinfo", "inxi", "meld", "nano-syntax-highlighting", "neofetch", "pv", "python-defusedxml", "python-packaging", "rsync", "tldr", "sed", "vi", "wget", "linux-lts", "linux-lts-headers", "acpi", "arandr", "arc-gtk-theme-eos", "archlinux-xdg-menu", "dex", "dunst", "eos-lightdm-slick-theme", "eos-qogir-icons", "eos-skel-ce-qtile", "feh", "gtk-engine-murrine", "gvfs", "gvfs-afc", "gvfs-gphoto2", "gvfs-mtp", "gvfs-nfs", "gvfs-smb", "lightdm", "lightdm-slick-greeter", "lxappearance-gtk3", "mpv", "network-manager-applet", "papirus-icon-theme", "pasystray", "picom", "polkit-gnome", "qtile", "rofi", "sysstat", "thunar", "thunar-archive-plugin", "thunar-media-tags-plugin", "thunar-volman", "ttf-cascadia-code", "ttf-nerd-fonts-symbols-2048-em", "tumbler", "xbindkeys", "xcursor-neutral", "xdg-user-dirs-gtk", "xfce4-terminal", "xorg-xbacklight", "xorg-xdpyinfo") 
2023-05-01 - 14:11:22 [6]: [PYTHON JOB]: "warning: xz-5.4.2-1 is up to date -- skipping" 
2023-05-01 - 14:11:22 [6]: [PYTHON JOB]: "warning: freetype2-2.13.0-1 is up to date -- skipping" 
2023-05-01 - 14:11:22 [6]: [PYTHON JOB]: "warning: findutils-4.9.0-3 is up to date -- skipping" 
2023-05-01 - 14:11:22 [6]: [PYTHON JOB]: "warning: sed-4.9-3 is up to date -- skipping" 
2023-05-01 - 14:11:22 [6]: [PYTHON JOB]: "error: target not found: ttf-nerd-fonts-symbols-2048-em" 
2023-05-01 - 14:11:22 [6]: [PYTHON JOB]: "error: target not found: xcursor-neutral" 

This is where Calamares tried to install the packages.
The key two lines are

2023-05-01 - 14:11:22 [6]: [PYTHON JOB]: "error: target not found: ttf-nerd-fonts-symbols-2048-em" 
2023-05-01 - 14:11:22 [6]: [PYTHON JOB]: "error: target not found: xcursor-neutral" 

So actually there are two culprits, ttf-nerd-fonts-sysmbols-2048-em AND xcursor-neutral.

I am now going to fire up cassini Nova and see where they may be eliminated in Calamares before installation occurs.


When in the liveISO and Community Editions are being installed, on the “Packages” section.
Scroll to the bottom of the list under Openbox and open “Openbox”.
Scroll down to


and uncheck it.

xcursor-neutral is not listed, but I believe xcursor-neutral is a dependency of

Try this and let us know how it goes.


Now that we know more about what is going on, I took the liberties of Editing the Topic’s Title to help users in the future to find this Topic. I hope that is OK.

Both packages are listed in (see also my reply above). Scroll down to the Openbox section.

OP needs to edit the file and remove them both.
Or perhaps replace ttf-nerd-fonts-symbols-2048-em with ttf-nerd-fonts-symbols which is in the repo.

Sorry my friend, I missed that. Must of been skimming instead of reading.
I like your suggestion because it offers a replacement package.

Also, I have cassini nova on my USB Thumb drive. EndeavourOS_Cassini_Nova-03-2023_R1 is a hot fix and might have taken care of this. I am now downloading the Cassini Nove R1 iso to test.


1 Like

No problem!
And you are right about the hotfix.
I like to remember that we had this issue reported before and consequently was fixed “hotly”.

1 Like

Downloaded Cassini Nova R1 and the problem is still there. However, there are discussions in the background about this problem. I believe a fix is coming.

I am still in the liveISO. I unchecked ttf-nerd-fonts-symbols-2048-em
I also tried to put ttf-nerd-fonts-symbols into /home/liveuser/user_pkglist.txt
but Calamares said that package was not available.

Install should be done. Now to reboot and see if OpenBox runs.


1 Like

Boot into Openbox was successful.

[don@OpenBox-Test ~]$ pacman -Q | grep ttf-nerd-fonts
[don@OpenBox-Test ~]$ sudo pacman -S ttf-nerd-fonts-symbols
resolving dependencies...
looking for conflicting packages...

Package (2)                              New Version  Net Change

community/ttf-nerd-fonts-symbols-common  3.0.0-2        0.04 MiB
community/ttf-nerd-fonts-symbols         3.0.0-2        1.81 MiB

Total Installed Size:  1.85 MiB

:: Proceed with installation? [Y/n]

Maybe I should have entered both of the above into /home/liveuser/user_pkglist.txt ?

Bottom line. Removing ttf-nerd-fonts-symbols-2048-em as in post 5 will allow installation of OpenBox and the rest of the Community Editions (except Sway which is OK)

A permanent fix is being discussed.


1 Like

ttf-nerd-fonts-symbols-2048-em was the issue with Sway also.

I tried like 1 h ago or less :slight_smile:

Removing it install was fine :slight_smile:

1 Like

Yeah, I work mostly on ARM stuff. For some reason Sway on ARM did not install ttf-nerd-fonts-symbols-2048-em so on ARM all Community Editions failed except Sway. So I misspoke when talking about x86_64. You are correct.


1 Like