Endevour running choppier and laggier than Manjaro?

Hello, I have this problem that I cannot understand why it is happening in the first place. It all started the first time i tried endeavor year and a half ago. I installed it on my work laptop as I thought it could work even better than Manjaro i have been using for years. The moment i installed Endevour I realised that its really chop and laggy in all places ( KDE Plasma ).

Moving windows arrounds was choppy, opening the taskbar items was delayed and laggy, and some software like teams from aur and browser were laggy as well ( tried both turned on and off hardware acceleration ). Then decided to switch to Manjaro and everything was perfectly fine. Now that spring has came I wanted to do some spring cleaning and to reinstall the system. I wanted to give a chance to EndeveourOS again so i installed it, but again it seems to have the same issues.

I want to use EndeveourOS over Manjaro but it aint letting me. Also when I installed displaylink and then whenever a second screen was active, the movement of windows became even more choppy. ( though i think i fixed that by installing evdi-git instead of evdi )

CPU: 12th Gen Intel i7-1255U (12) @ 4.700GHz
GPU: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics]
Memory: 39792MiB
ThinkPad E15 Gen 4

Welcome to the forum. Post some details about your hardware, please.

inxi -Faz
1 Like
  Kernel: 6.7.5-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: initrd=\7839776ec751490c9f23b3ac7b4358cd\6.7.5-arch1-1\initrd
    nvme_load=YES nowatchdog rw
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 21E6S0X500 v: ThinkPad E15 Gen 4
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 21E6S0X500 v: SDK0T76530 WIN
    serial: <superuser required> part-nu: LENOVO_MT_21E6_BU_Think_FM_ThinkPad
    E15 Gen 4 uuid: <superuser required> UEFI: LENOVO v: R1SET49W(1.20)
    date: 04/13/2023
  ID-1: BAT0 charge: 54.5 Wh (100.0%) condition: 54.5/57.0 Wh (95.5%)
    volts: 12.9 min: 11.5 model: Celxpert LNV-5B11C73245 type: Li-poly
    serial: <filter> status: full cycles: 38
  Info: model: 12th Gen Intel Core i7-1255U bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 4
    microcode: 0x430
  Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
    cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
    L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 513 high: 697 min/max: 400/4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 460
    5: 662 6: 694 7: 400 8: 617 9: 697 10: 400 11: 630 12: 400 bogomips: 62688
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB:
    conditional, RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:46a8 class-ID: 0300
  Device-2: Chicony Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:4 chip-ID: 04f2:b71f
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.11 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: evdi,i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
    s-diag: 1052mm (41.43")
  Monitor-1: DVI-I-1 mapped: DVI-I-1-1 pos: right model: ASUS VG249
    serial: <filter> built: 2020 res: 1920x1080 dpi: 93 gamma: 1.2
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: primary,left model: AU Optronics 0xe48d built: 2019
    res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: iris x11:
    drv: iris inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.1-arch1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:46a8 memory: 37.95 GiB unified: yes
  API: Vulkan Message: No Vulkan data available.
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Device-2: DisplayLink ThinkPad Hybrid USB-C with USB-A Dock
    driver: snd-usb-audio,usbfs type: USB rev: 3.2 speed: 5 Gb/s lanes: 1
    mode: 3.2 gen-1x1 bus-ID: 2-1.2:3 chip-ID: 17e9:6015 class-ID: 0102
    serial: <filter>
  Device-3: Trust GXT 242 Microphone
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 3-1.4.1:8 chip-ID: 145f:0257 class-ID: 0300
  API: ALSA v: k6.7.5-arch1-1 status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlan0 state: down mac: <filter>
  Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1a1f class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-3: Lenovo ThinkPad Lan driver: cdc_ether type: USB rev: 3.2
    speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-1.3:4 chip-ID: 17ef:a359
    class-ID: 0a00 serial: <filter>
  IF: enp0s13f0u1u3c2 state: up speed: 1000 Mbps duplex: half mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:6 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
  Local Storage: total: 593.04 GiB used: 29.37 GiB (5.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: KIOXIA model: N/A
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 1108ANLA temp: 24.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: SMI (STMicroelectronics)
    model: USB DISK size: 116.1 GiB block-size: physical: 512 B logical: 512 B
    type: USB rev: 3.1 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A
    serial: <filter> fw-rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 195.31 GiB size: 191.19 GiB (97.89%)
    used: 10.75 GiB (5.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /home raw-size: 273.12 GiB size: 267.78 GiB (98.04%)
    used: 18.54 GiB (6.9%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p1 maj-min: 259:1
  Src: /sys System Temperatures: cpu: 34.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 40 GiB note: est. available: 38.86 GiB used: 7.44 GiB (19.1%)
  Processes: 473 Power: uptime: 7h 15m states: freeze,mem,disk
    suspend: s2idle wakeups: 2 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 15.54 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1001 libs: 226 tools: yay Compilers:
    gcc: 13.2.1 Shell: Zsh v: 5.9 running-in: konsole inxi: 3.3.33

there should be BIOS updates, that could by a small chance help.

install vulkan: sudo pacman -S vulkan-intel lib32-vulkan intel

Try installing wayland: sudo pacman -S plasma-wayland-session and choose that at login and check if the issue also happens there.

1 Like

Have you tried installing any other Arch Linux based systems, i.e. Arcolinux, Archman, Archcraft, Garuda, or RebornOS? Just curious if other Arch spins are giving you similar results?

I have not on this laptop

Manjaro ran well on both xserver and wayland

Manjaro is another distribution that is based on Arch but is not Arch. Manjaro holds back updates and does a lot of its own things. Not trying out something from someone who is trying to help isn’t going to encourage others to help

1 Like

i never said i didnt try wayland on Endevour, I only shared my finding on manjaro, on endevour it seems it makes no noticable difference, maybe its a bit better but it could be my eyes playing

I think you misunderstand me. I am saying that Endeavour is NOT Manjaro. It is a different team with a different philosophy and a different approach to users. Manjaro does things its own way. They are two different projects with two very different approaches.

Alright then, i shall not be comparing Manjaro with EndevourOS then. Also after everything above combined, it might be running slightly better, ill need a few days to see

Is your monitor and laptop both at the same refresh rate? On x11 it defaults to whichever has the lowest refresh rate for both screens, with wayland it won’t have that problem. This could explain why it feels choppier and laggier. Also make sure you have the correct refresh rate in KDE system settings but I’m assuming that was already set.

If you happen to have package xf86-video-intel installed, uninstall it and reboot.

I feel ashamed to admit that I have found what the issue was and so by accident. I realized I haven’t heard the fans on the laptop spin for a long time, and immediately checked the power settings…


Seems like even though I had the laptop plugged in it didn’t make it automatically go to performance mod how I guess KDE on Manjaro was configured and never thought of checking it. Well anyways I learned a lesson today and thanks for y’alls help.


It’s all good when it ends good!

Welcome to EnOS’ community @GyroZepelix!

:enos: :handshake:t5:

Thanks o7