EndeavourOS stutters and lags every 1 second

Hello
I wanted to test out EndeavourOS in a virtual machine, so I installed it using the KDE desktop environment. Everything installed fine, and booted up normally, but when I got to the desktop, I noticed that clicking on buttons and stuff was delayed or just didn’t register. I moved some windows around and noticed that they would ‘teleport’ as the desktop was lagging. My host’s performance was fine, and wasn’t using much resources. Whenever I typed something, sometimes it would be repeated (for example tttttttthis) and the VM was practically unusable.
I later reinstalled this distro but I used Cinnamon as it was lighter. Same problem, but less pronounced.
The text repetition wasn’t as bad, but the windows still lagged.

This doesn’t happen on any other distro I’ve tried, not even other Arch based distros.
What can I do? (videos attached)

specs:
Intel Core i7-1165G7 4 core (2 allocated to vm)
16GB RAM (5GB allocated to vm)
Intel Iris Xe integrated graphics

http://ix.io/4GpN (VM)
http://ix.io/4GpO (VM hardware info)
image (partition and format info)
rest of the logs (limit of 5 links) https://pastebin.com/N0zwyXey

videos:
https://streamable.com/hcprba
https://streamable.com/p413ba

Any help?

Did you try with virtualbox ? Vmware don’t list Arch in they’re supported OS.

when I installed last, about a couple weeks ago, there are three live versions. did you try them all?
edit: three live versions in the boot menu I mean (grub/uefi/nvida/no-nvidia/something-like-that versions)

This appears to be scsi_eh issue. Start top or btop and monitor if scsi_ehXXX processes are hogging the CPU. More info here https://bbs.archlinux.org/viewtopic.php?id=288723

As a workaround try installing linux lts kernel in your VM and use that

yay -S linux-lts linux-lts-headers

Edit: Yep, it seems that’s the culprit. Installed EnOS in a VMWare player just now. Barely usable VM with kernel 6.5, and everything works okay on 6.1 LTS

2 Likes

Is Kde host running on Wayland?

@Cookie
Edit: Also we have noticed on vmware that you need to set the settings to SATA instead of IDE. This is done under customize hardware, advanced and set to SATA.

So I tried to install it again, and this time the installer is failing with ‘Failed to run pacstrap’.
I was going to try what people here said, but if the OS is not installing, then I don’t know what to do.
Log: https://termbin.com/bqr2

Nevermind, just used Installation Failed with pacstrap error for help and it works. Now i’ll try the lts kernel fix. I also set the settings to SATA.

Thanks, I installed Linux lts and lts-headers in the installer, and the VM works fine now.

I have no issue using the current kernel on vmware.

Maybe it’s a difference between VMware workstation and player, or because you’re running a Linux host (i have windows host)

Maybe that’s possible. I’m running linux host with vmware workstation pro.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.