Endeavouros randomly freezes

The OS randomly freezes, I already switched to the LTS kernel, but it seems like that was not the issue.
I don’t know what causes it. It may be the hardware, so below is the output of the lshw -short command. Is there a way to troubleshoot this issue? It’s really frustrating when it freezes in the middle of a coding session… :))
Screenshot from 2022-08-17 12-59-57
Screenshot from 2022-08-17 13-00-20

If you have already tried switching kernels, the next thing to do is test your memory.

Frequent hard freezing is usually caused by hardware or drivers.

Could you post the link for this command for your hardware?

inxi -Faz | eos-sendlog
System:
  Kernel: 5.15.60-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-lts
    root=UUID=7d173a4b-9955-42eb-889d-3feb1e3e1e67 rw loglevel=3 nowatchdog
    nvme_load=YES
  Desktop: GNOME v: 42.4 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 81RS v: Lenovo Yoga S740-14IIL
    serial: <superuser required> Chassis: type: 10 v: Lenovo Yoga S740-14IIL
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: BYCN39WW date: 05/28/2021
Battery:
  ID-1: BAT0 charge: 53.6 Wh (94.2%) condition: 56.9/62.3 Wh (91.3%)
    volts: 17.4 min: 15.4 model: SMP L19M4PD2 type: Li-poly serial: <filter>
    status: charging cycles: 970
  Device-1: hidpp_battery_0 model: Logitech M720 Triathlon Multi-Device
    Mouse serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake
    gen: core 10 built: 2019-21 process: Intel 10nm family: 6
    model-id: 0x7E (126) stepping: 5 microcode: 0xB2
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1099 high: 1101 min/max: 400/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1095 2: 1100 3: 1100
    4: 1100 5: 1100 6: 1100 7: 1100 8: 1101 bogomips: 23961
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Iris Plus Graphics G7 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
    empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0 chip-ID: 8086:8a52 class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX250] vendor: Lenovo driver: N/A
    alternate: nouveau non-free: 515.xx+ status: current (as of 2022-07)
    arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 3
    speed: 8 GT/s lanes: 4 bus-ID: 2b:00.0 chip-ID: 10de:1d13 class-ID: 0302
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-5:3 chip-ID: 04f2:b67c class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0x5a3d built: 2018 res: 1920x1080
    dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) v: 4.6 Mesa
    22.1.6 direct render: Yes
Audio:
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-icl
    alternate: snd_hda_intel,snd_sof_pci_intel_icl bus-ID: 00:1f.3
    chip-ID: 8086:34c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.15.60-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
Drives:
  Local Storage: total: 505.84 GiB used: 29.99 GiB (5.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLB512HBJQ-000L2 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 3L1QEXF7 temp: 45.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Kingston
    model: DataTraveler 3.0 size: 28.9 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 48.16 GiB size: 47.1 GiB (97.80%) used: 21.56 GiB (45.8%)
    fs: ext4 dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 316 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-3: /home raw-size: 38.2 GiB size: 37.3 GiB (97.65%) used: 6.73 GiB
    (18.0%) fs: ext4 dev: /dev/nvme0n1p9 maj-min: 259:9
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 58.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 263 Uptime: 16m wakeups: 1419 Memory: 7.33 GiB used: 3.32 GiB
  (45.3%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1048 lib: 247
  Shell: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.20

As a stated earlier, start by testing your memory.

Next go through the logs for errors. Although, hard freezes often don’t show up in the logs.

And only 8 GB of RAM. Can that be the issue?

1 Like

Definitely could be.

I think it needs the kernel parameter ibt=off and then update grub. No drivers are being used for the nvidia mx250. Then check if nouveau open source is being used and or install the nvidia drivers.

1 Like

It is a 10th gen mobile ice lake cpu and the same behaviour is seen with the LTS kernel. Why would ibt=off be needed here?

I’m not sure but it seems that all the users I see that have this issue of the drivers not showing nouveau or Nvidia even if they install the drivers. Then with the kernel parameter show drivers installed or nouveau. I think is worth trying and see if it helps with the freezing issue or not. :person_shrugging:

I thought this was just an nvidia issue requiring the ibt=off It is related to it only if the cpu is a certain Intel? :thinking:

My understanding is it only applies to kernels 5.18 or later when you are using 11th or 12th gen intel cpus and nvidia drivers.

Set up SysRq and try recovery next time you get a freeze:
https://wiki.archlinux.org/title/Keyboard_shortcuts#Kernel_(SysRq)

Is 8GB of swap memory enough? Also I didn’t have freezes on Manjaro…

Yes this is certainly enough.

How much swap did you have with Manjaro?

1 Like

I didn’t have any

I reinstalled the system with 8bg swap memory, but I’m still getting freezes. Should I go with the -b or -n option?
image

Why don’t you run a test first.

nvidia-installer-dkms -t

Show the output of this.

Edit: If the test runs without error i would install the nvidia drivers first.

nvidia-installer-dkms

Then see what happens on a reboot. Does it boot properly and are the nvdia drivers installed? I think i would still use the kernel parameter ibt=off also. But you could try it first without. See what it shows for drivers after.

inxi -Ga
1 Like

I don’t know how to set the kernel parameter ibt = off, but so far I had no freeze. I assume the nvidia driver solved the problem. Also 1.5GB is used from swap memory, so probably both were needed.
Here is the ouptut for inxi -Ga command:
image

I see the drivers are installed for nvidia and showing up so i don’t think you need the kernel parameter anyway. It is running on Intel graphics. If you wanted to use nvidia graphics then you need some method to switch such as optimus-manager or some other. Hopefully no more freezing maybe?