EndeavourOS not showing up in Boot Menu

Hi Guys,

Recently switched to EOS yesterday and I seemed to have run into a strange issue today.

I did a update recently and now when I boot I only see the following options in the Linux boot menu.

  • Windows 10
  • Firmware

Any idea how to make EOS show up again?
I did a backup last night in case I brick something, but I cant even get to it.

Any idea how to get back in?


Following the wiki instructions. arch-chroot into your system and run reinstall-kernels

Ensure the EFI partition is mounted in the chroot.


1 Like

Thanks, that made it appear.

But now I have it stop booting due to the following error.

Malformed MSFT vendor event: 0x02


I tried the following from another post but no luck yet.

Try CTRL+ALT+F2 when it hangs or F3, F4, F5 then login when you get the prompt.

Then disable sddm, lightdm gdm whatever you are using with this command

sudo systemctl disable sddm.service or lightdm.service or gdm.service . I dont know wich you use.

Then reboot. You should get to a prompt with only text

I tried updating from the tty and got a odd error that I saw before all of the issues happened.

Command: yay


/var/lib/pacman/db.lck is present
There may be another Pacman instance running. Waiting…

Tried the following.

sudo rm /var/lib/pacman/db.lck

The command removed the lock.

Updated the system with yay


Still have the malformed MSFT error.

I’ll close this thread as solved and create a new one as the original problem was solved.

Thanks again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.