EndeavourOS installer (online) keeps failing

Today when I tried to install EndeavourOS (with KDE) it installed but for some reason KDE wouldn’t load and I had to use the terminal interface. When I tried to again by reformatting the partitions and when i clicked on the install button, it would install but after when it is above 90% (not too sure exactly where) it will keep showing an error message.

I reformatted my USB drive before the 3rd attempt and the same issue occurred (this time I decided to also install mouse tricks (or whatever it was called).

2020-02-22_15-17

@unix_lover
Not sure exactly how you are trying to install EndeavourOS but i can tell you this. The online installer for me and most others works flawlessly. It has right from the beginning. I always create my live ISO in Linux with Etcher and i have no issues ever with it. As far as installing, if you can; it is best to wipe out the existing partitioning by using gparted and creating a new global GPT. In gparted it is device, create partition table, GPT. Then run the installer and let it either erase disc and swap or hiberbate or do manual partitioning. It is NOT the online installer that is the problem. It can be Calamares sometimes depending on the circumstances and that is what i know from all the installing and testing. I rarely get a failed installation especially on the current ISO as i am testing for future releases. I am running KDE and sometimes i do 5 or 6 installs one after the other almost every other day.

My suggestion is to try it this way as i have stated. It does no good at all to put up a topic and state this without providing logs and background information. The devs have no way of knowing what you have done and what has gone wrong without information and logs. When you do an install from a live ISO even if it fails you can send the install log. Before you close it out post the output of the following command. Also provide an explanation of exactly the process you do. Then maybe they can understand and look at the logs when they have the time to see what has happened.

cat ~/endeavour-install.log | curl -F ‘f:1=<-’ ix.io

Reformatting doesn’t always work and I’m not saying you have to do this every time but this is what i would do if i am having an issue like this. Give it a shot and post the log if necessary.

Edit: Here is the command to also send the output for your hardware.
lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F ‘f:1=<-’ ix.io

I have installed it many times on virtualbox and I just installed it few days ago on another computer with no issues.

I did wipe out the EndeavourOS partitions with gparted (not through the installer).

When you say this does it mean to create a new partition table that is GPT?

Come to think of it I think it might have been BaleneEtcher and Windows 10 as it acting a little funny. When flashing my USB drive, Windows 10 for some reason says (insert Disk D:) and I click on close and BalenaEtcher continues to write to the USB drive. This time I managed to flash the USB drive without that annoying error message so hopefully it works now.

Sure I will keep this in mind. If it fails again then I will submit the logs.

Are you installing it in vbox? If so you don’t need to use a live usb. Just download the iso and you load it from that when using vbox.

Also i can tell you that creating a live usb from Windows on Etcher for me doesn’t cut it and gives problems. I only use Linux to create my live usb with Etcher. I’ve had issues with Windows in the early days so i just don’t go that route. I never have an issue with etcher on Linux. Like i say i do this many many times a day and or night. Do you have another Linux installation you can use?

In gparted yes you use device, create partition GPT and it wipes out ALL existing partitions and then you can either create new ones right there and then or close out gparted and start the installer and do it as you go with eiher manually or automatic process. It doesn’t matter then. What matters is that when you create a global partition GPT it destroys all existing partitions and you start fresh. Like i say you don’t always have to do this. I’m just saying it usually solves the problem unless it’s the live usb which i’m thinking it is also. So at this stage i would do both.

One thing you can try to do is to format the partition you intend to use for Endeavour with GParted from the live CD.

1 Like

So the live ISO again has failed. After attempting to install I ran this command after attempting to install cat ~/endeavour-install.log | curl -F ‘f:1=<-’ ix.io But I get this error message bash: -’: No such file or directory.

Nah I am using actual computer.

Ok I will use Linux with Etcher next time.

Yes I do I could give that a try.

I don’t want to do that as I have got Windows installed.

That is exactly what I am doing. I have installed this operating system before on the same PC and I have had no issues. I don’t know why is it having issues all of a sudden?

I guess there was a typo in the command. That is why it was not working before.

I copied and paste the command from EndeavourOS’s website and here is the link to the error logs.
http://ix.io/2cmC

Okay so did you do another install? Did you create a new usb? Did you wipe out the partition and create a a new GPT?

I have Windows installed so I don’t want to create a new partition table. I just removed the paritions where EndeavourOS was previously installed and formatted the paritions.

No I haven’t yet. I will try with Manjaro now and see how this goes.

I hope this helps what I have posted.

I’m not the expert on reading these logs but i see /dev/sda2 has no fs
Are you able to boot on live ISO and give me a screen shot of gparted?

Sure give me a sec.

I also have one question. Are you trying to install it using luks? (Encryption)

yes correct. This has worked before on the same PC. I am making the home partition encrypted but not the root partition.

here is the screenshot.

Okay i see that /dev/sda2 is a windows reserved partition. That explains it why the log say’s unknown fs. I’m not used to the partitions being out of order. It’s funny because i have been doing testing on luks full encryption all week. I haven’t had any failures but i’m not using that ISO. I would suggest you install it without encryption to see if you have the same issue or any issue at all. I think that there have been issues with luks and Calamares and the devs are working on it. Could you try an install without encryption? Then post the log so they can compare. So do the same as you tried but without the encryption. I would appreciate that.

Edit: The other thing that i notice in the log and also on the screenshot. It shows the encrypted home as full with zero space left.

1 Like

Ah I see.

Is it out of order in the log?

Yeah I believe you can only encrypt one partition only with this installer.

Are you using a new ISO image that has not been released to the public yet?

I think I might know what is going on. Before there was unallocated 1 MB partition between Windows and EndeavourOS’s root partition. Since I removed that when reinstalling Endeavour I think that is what is causing the issues. Since I am using UEFI its a bit more confusing how this parititioning thing works with GPT vs MBR.

The issue I remember was that you can’t encrypt more than one partitions.


Ok nevermind I installed it without any issues. The problem once again was I needed unallocated parition between Windows and Endeavour, that is what was set before. I just saw your post when I attempted to again install EndeavourOS with that new partition added.

Yes i think you are correct that only one partition can be encrypted currently. As you can see one little issue ruins the install. So what you are saying is it needs a small space between the Windows partition and the Linux partition?

Uefi is no big deal. Is this a laptop? Or desktop computer? On my system i have Windows installed on an m.2 drive with EFI partition and all the Windows partitions required. I have EndeavourOS installed on a separate SSD drive with an EFI partition plus root, home and swap. I have zero issues and i can wipe out and reinstall and not have any problem. Do it every day or every other day or sometimes many times a day. My partitions are usually in order and for the most part i try to keep it that way but i know it can’t always happen. It depends on things and it can be confusing. Glad you got it installed and can you please mark your posts solved. Thanks.

2 Likes

Yes that is true unfortunately, I hope this can be fixed one day.

Yes, I remember when I create any partitions for a UEFI system which has Windows installed (this includes VirtualBox as well if set to EFI mode), when I resize the Windows parition, I can’t exactly remember but it would normally automatically place an unallocated space between Windows and Linux and between certain other partitions as well. I have no idea how this works or why this is required, if anyone can explain to me I would love to know why.

Its a laptop.

I am assuming this is a desktop/tower computer, right? With your m.2 SSD, is it NVMe or SATA?

Is there a benefit to have a swap partition rather than a swap file?

May I ask how come you reinstall Endeavour many times? Does Endeavour screw up many times?

With my last install it was a bit out of order but thankfully this time it is in order ( I think so).

Yes it can get confusing, its even more confusing for GPT partition tables for me personally.

Thanks mate :slight_smile:

Already done :+1: