EndeavourOS installation fail [SOLVED]

Hi. I’m a regular Windows casual user. Had a couple of swings with multiple distro before, including EndeavourOS. After a break from messing with Linux, i decided to try it out the distro again. This time though it seems like something’s gone wrong with the installation.

Log: https://termbin.com/hr6n

Things I have tried:

  • Update mirrors for Arch and EndeavourOS
  • Redownload ISO
  • Select GNOME, KDE Plasma, and No Desktop. The first two end at ~36% and show the exact same log as the attached link. The last end at ~60% mark and return ‘bad [something] script’
  • Use these two lines of code: sudo cp /etc/calamares/settings_online.conf /etc/calamares/settings.conf sudo calamares -D8 | tee endeavour-install.log, as indicated in Calamares initialization failed - #6 by dalto

I suspect the error is because the script is trying to install nautilus-sendto which i couldn’t manually find using pacman -Ss

There is a known issue with gnome. This is what is your logs.

You can solve it by unchecking nautilus-sendto under gnome on the packages selection screen.

I am not sure why kde or no desktop would have failed. Those would not try to install nautilus-sendto I would need to see logs from those options to know for sure.

If you want KDE, you can always do an offline installation. That will get you KDE and will be more reliable than an online install.

1 Like

Hmm now it show bad main script file again.

http://termbin.com/nj0q

ERROR: Error while running: OSError: [Errno 30] Read-only file system

Your EFI partition is read-only. You may need to repair it before starting the installer.

I’m getting better at this, this was the line I noticed. I like following these threads and looking at the logs and advice that is given. I wouldn’t have had any idea of a fix but by watching this I’ll learn some more.

Apparently I don’t know how to repair this lol.

I did look up and saw your guide on how to fix a similar issue. https://forum.endeavour.com/t/install-failing-due-to-read-only-efi-partition/36542/7. I chose manual partitioning and create a partition from the empty space, but then the installer doesnt allow me to continue when i click on any of the partition.

I then chose the first option and tried to shrink 20mb of my existing partition. Still the issue of “bad main script file”.

I then went to Windows to try to make a partition of the free space i have on disk and boot from the USB, but installer still recognizes it as free space.

Here is the result from sudo parted -l after all of this:

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  106MB  105MB   fat32        EFI System Partition          boot, esp, no_automount
 2      106MB   123MB  16.8MB               Microsoft reserved partition  msftres, no_automount
 3      123MB   158GB  158GB   ntfs         Basic data partition          msftdata
 4      158GB   159GB  1074MB  ext4                                       bls_boot
 5      263GB   398GB  136GB   ntfs         Basic data partition          msftdata
 7      398GB   420GB  21.8GB  ext4         endeavouros
 6      511GB   512GB  813MB   ntfs                                       hidden, diag, no_automount

And here is the log: https://termbin.com/kt3x

Wondering if this is a big enough partition for EFI? Just from what I’ve read it should be bigger than this (only making guesses at things, don’t do a thing til someone smart advise it)

im not sure about the 100mb. dont know where it comes from. and didnt actually notice it until now.

if this matters then it is new to me. Didn’t know i have to make a reserve for EFI.

Yer don’t touch anything like I said til someone smarter can help but from my online searches it seems it should be bigger than that if you are using 2 OS

1 Like

What partition are you intending to use as ESP aka EFI System Partition?

If this one:

then the size is alright but not the format. It should be FAT32.

Then depending on the bootloader, the mount point should be:

/efi for systemd-boot

/boot/efi for Grub

In any case, it should also be flagged as boot.

Can the OS share the same ESP as Windows? Im intending the esp to be the first partition, 100mb FAT32

I’ve also been exploring and it does seem like ESP is unmounted. Lemme try out your solution.

It can. However I am not sure what the minimal size requirement for ESP is in EnOS.

At any rate, it is too small for systemd-boot. For systemd-boot the size should be min. 1024MB.

For Grub, it is alright, but yet, I believe the EnOS has a min. size requirement.
If I remember it correctly, it is set in one of the installer’s config files.
It has been quite a while that I have not looked at them so I can’t tell which one you would need to edit before launching the installer.

At any rate, letting each OS have its own ESP can have at least one advantage, that is, the risk that a future update in Windows overwrites your Linux’ bootloader is effectively eliminated.

There have been occasional reports here on the forum attesting to this.

Personally, I would opt for a separate ESP.

3 Likes

I’d recommend backing up any personal data to an external drive before doing anything else, just in case.

The 100MB partition is not big enough to hold the stuff that needs to be written there, so another fat32 partition solves that.

3 Likes

when i tried mounting it said /efi: mount point doesn’t exist

How are you mounting what?

tried to mount a new partition intended for esp of enOS onto /efi. it said /efi doesnt exist.

but then i tried mkdir /efi and it works now.

Please respond to the question being asked!

You don’t need to make an /efi directory in the live session to mount any partition.

This is done by the installer when you choose the manual partitioning (or otherwise).

So I am asking again:

What partition are you mounting?

How are you mounting it, command line?

Where are you mounting it, in the live session’s filesystem?

Please don’t be “telegraphic” and give detailed answer!

2 Likes

I am mounting partition 4 as you suggested earlier.

I first sudo mount /dev/nvme0n1p4 /efi. It returns /efi does not exist

I then sudo mkdir /efi to mount the partition.

Sorry for the undercommunication.

As I mentioned, you don’t need to make any directory in the live session’s filesystem for mounting any partition there. At least not for the purpose of installing the system with Calamares (the GUI installer)

So, if this is going to be ESP for your EnOS, here is what you need to do:

  1. unmount it first from where you mounted it previously

  2. launch the installer

  3. choose manual installation, choose systemd-boot (default)

  4. when you reach the partition screen:

    4.1. choose partition 4 >> mount point /efi ; frormat FAT32 ; flag boot

    4.2 choose partition 7 (I suppose that is where you want to install the system). Choose format EXT4 and mountpoint /

  5. Go on with the installation

2 Likes

hey installation is successful. thanks a lot for helping!

1 Like