EndeavourOS Hiberanation failed

I am a newbie to the endeavour community and just dual booted in my system with windows 11. I installed by cloning a git repository by prasanth rangan. Here is the link for it :- https://github.com/prasanthrangan/hyprdots. I created a manual partition in my hard disk to install the OS.

I tried the instructions from:

but still when i try to hibernate my system, it fails and abruptly shuts down terminating all the applications that i had opened.

Please guide me to setup hibernation mode for my system.

Did you get an appropriate swap device set up?

Here is guidance from the ArchWiki for setting up hibernation: https://wiki.archlinux.org/title/Power_management/Suspend_and_hibernate#Hibernation

The only difference is in your case will be the “Configure the initramfs” section, where you should use dracut instead of mkinitcpio. Here are the steps to do that:

Create a config file in /etc/dracut.conf.d/:

sudo nano /etc/dracut.conf.d/resume.conf

You can use any editor you like in place of nano. Also the file can be called anything you want, so long as it ends in “.conf”.

Paste in this line to add the module:

add_dracutmodules+=" resume "

Be sure to include the spaces between the quotation marks, before and after “resume”.

Then rebuild the initramfs:

sudo dracut-rebuild

Other than that just follow the steps outlined in the wiki (from 4 Hibernation through 4.3 Required kernel parameters).

Thanks, but I had the resume.conf file already with the same line. I created a new partition in my hard disk with an unallocated space of 16 GB that i had shrunk with windows 11. Then used the partition as linux swap. Now, I can use it for hibernation mode. I am not clear of what i have done but still works :laughing: