EndeavourOS freezes with any browser

I have just moved from Ubuntu 16 to EndeavourOS and it’s been a breath of fresh air.

My issue is that my machine hangs when ever I use a browser. At first I thought it was Firefox so I removed it and installed Opera but it freezes with that and Qutebrowser too.

The symptom is the screen freezes but I can still move the mouse and have no keyboard input.

I am wondering if it is some kind of graphics/hardware acceleration issue because it’s guaranteed to happen in YouTube.

I tried to update the Nvidia drivers using nvidia-installer-dkms but that just lead to a blank screen on restart and I reinstalled the OS from scratch. (I also tried to install the linux-lts-headers from the live ISO but that didn’t help)

Does anyone know what I could try to fix this issue?

My specs are a 2009 24 inch iMac:
Intel core 2 duo 2.66ghz
Nvidia geforce 9400
4gb ram

Terminal usage is completely fine, it just seems to hang using a browser.

I had a similar issue with my installation and I figured what was causing the black screen when booting up.

I chose the offline method of installation and it installed Nvidia drivers which was the root cause. One of the members here helped me look into the issue and helped with downgrading the drivers to 3XX.

However, when I reinstalled using online installation, I think Nvidia wasn’t installed and PC booted just fine. I believe the open source nouveau drivers were installed.

My Nvidia card is from 2007 or so.

How did you install the OS?

You can access terminal boot if it shows Starting Arch 249… by pressing Alt Ctl F1 or F2. You can remove Nvidia drivers and see if that helps.

Thanks for helping me out, I really appreciate it.

That’s interesting. The installation I went for was online with the community bspwm and not the xfce offline version.

That’s helpful to know. When I tried to upgrade the Nvidia drivers, on reboot I got a black screen with a blinking white cursor and the keyboard didn’t seem to work. Perhaps I tried the wrong key combination.

The black screen isn’t the main issue though, it’s the hanging when trying to use video in a browser and that leads me to suspect it’s a graphics driver issue. It could also be a old/dying graphics card.

Did you eventually get the system working?

Hi @Polymorphism and welcome to the forum :grin:

Not easy issue since you are using an older Mac model.

Yes my system is quite snappy for 12+ years old hardware and one of the main reasons I like Arch base.

I didn’t even bother with Nvidia drivers. Just using what came with the installation. I also have LTS kernel but just boot into main one without any issues on YouTube or anything.

Blank screen with cursor is likely graphic card issue. There is a terminal command which shows the logs but I forget now.

Try removing Nvidia drivers and see if it resolves it.

1 Like

Thank you :grin:

Yes, I suspected that. It mostly still works for my purposes and so I won’t get rid of it yet. Having said that, I’m not ruling out hardware failure as a cause either!

That sounds promising :slightly_smiling_face:

I’m a bit of a noob with Arch Linux, why do you have the LTS kernal too?

Do you know how I can remove the drivers?

Just fyi, in the eos welcome app there is a button to install a kernel management gui tool. Then you can easily install lts in addition to your existing kernel and choose at boot.

Thanks helping me out with this :slightly_smiling_face:

I’m new to the lower levels of Linux, why would it be beneficial to have different kernels, especially the LTS version?

LTS is the long term release, and generally though as more static/stable (not sure these are the right words) than the newer kernel. Don’t get me wrong, I generally run the newer kernel, and no problem at all.

Sometimes older hardware doesn’t like updates on the newer kernel, so you have a fall back just in case something goes wrong. I would say that is especially useful if you use nvidia graphics with proprietary drivers which are a pain. It’s a good precaution to avoid any trouble along the way.

1 Like

Ah excellent, that sounds like a really good precaution. I though LTS meant “latest” and not Long Term Release - silly me. I would actually prefer to run that as the main one actually.

I’ve just searched for it with pacman -Ss and it comes up with:


Should I install the first two with pacman and ignore the nvidia package?

Additionally, I’ve just compiled/ran a small game dev project using raylib and the graphics are rendering completey fine. Glxinfo returns the correct version of OpenGL.

You can check which of the Nvidia driver versions support your card with command:

nvidia-driver-supported-branches -a
1 Like

I just use the welcome app to install the kernel management tool. Then open it, it’s called akms and tick the boxes for lts. That’s at least the way I do it to avoid breaking anything. But in principles you could just install them via pacman, two packages you mention above.

No need for nvidia-lts. When you install nvidia-dkms it should work on all your kernels to my knowledge, that’s what dkms stands for.