EndeavourOS fails to boot into the DE

Hi everyone, I recently decided to try out EndeavourOS. The installation went pretty smoothly and everything was fine. Updated the system, installed some packages from pacman, built some other packages from the AUR using yay. After that I shut down the computer.
When I turned it back on, it stopped booting me in my DE of choice (Gnome in this case). Instead after the list of checks in the beginning start, it abruptly stops and all the text disappears leaving only a flashing line at the top-left. It stays there for a long time(trust me, I let it stay on for a while).


The checks usually stop here


This is the flashing line I’m talking about

At first, I thought maybe something was wrong with the bootloader, so I chrooted into my system using the live ISO and reinstalled grub. But all that did is make an extra boot option in the bios. The same thing happens when I go through the newly created one.

I don’t understand what’s going on, and since I’m a newbie I don’t know how to even approach troubleshooting something like this. if anyone has any suggestions, that would be great.

Update: Thanks everyone for responding so fast. I decided to reinstall the OS and carefully pick and choose the packages I installed and rebooted every time I installed one to see which one was the problem and it seems like steam was the culprit. more specifically steam with nvidia related drivers and stuff. I decided to install non-nvidia steam and they work and the computer boots fine.
Now as other people have stated My graphics card should be supported by series 390 drivers, so it’s weird that nvidia-inst says it’s not supported. I decided to try nvidia-installer-dkms, and that did manage to install a driver but after a reboot the system stops booting as usual. fortunately I installed Timeshift and created a backup of my root, so I could revert any changes. It seems like I can’t mess with my graphics driver in any way, either through installing steam or installing a proprietary driver. I guess I’ll be sticking with nouveau for now even though it bugs me why this happens.
once again thank you to everyone that replied, I’m not sure if this is solved or not but I can reach my PC now. That counts for something I guess.

Can you give your hardware details like CPU, GPU, Motherboard etc. ?

Motherboard: Gigabyte H110M-S2PT
CPU: Intel Core i5-6400 ×4
GPU: Nvidia Geforce 740 GT
RAM: 8 GB

First off, thanks for giving EndeavourOS a try. Welcome to the forum, I hope you enjoy your time here.

Anytime everything was fine, installed some packages and / or update packages, now it won’t boot getting blank screen with flashing cursor. This scenario is 90 percent or higher a result of video problems.

I see you have an Nvidia graphics card. Did “Updated the system, installed some packages from pacman, built some other packages from the AUR using yay” include anything to do with graphics or Nvidia drivers?

Pudge

1 Like

I’ll list the packages I installed.
AUR packages:
Timeshift
Steam with nvidia-utils as provider
Chromium
Pacman:
Musescore 3.6
Bitwarden

Now that you mentioned this, I also previously had a problem with Manjaro where trying to update the system and by extension the Kernel–which was 513 at the time–resulted in some sort of a conflict with the proprietery Nvidia driver. And after restart didn’t boot, kind of similar except it was stuck on a “recovering journal” prompt. Honestly I couldn’t understand what to make of it.
Part of the reason I tried EndeavourOS was because I thought I could circumvent that conflict by installing a distro with a newer kernel and a blank slate. Of course I didn’t know what I was doing and was just running away from the problem.

Which proprietary Nvida driver did you install, and how exactly did you install the proprietary Nvidia driver?

There is
nvidia
nvidia-lts
nvidia-dkms

The best way to install Nvidia drivers is with
$ sudo pacman -S nvidia-dkms
nvidia-inst -t

This automatically rebuilds the nvidia kernel module every time a new kernel is installed.

Pudge

EDIT:

2 Likes

It was probably the default proprietery driver that came with Manjaro xfce installer. Right now I’m positive that nouvea is installed on endeavourOS.

Though I will try your suggestion as soon as I can.

1 Like

If you are running nouveau only, it should boot up.

Actually, disregard
$ sudo pacman -S nvidia-dkms

There is a new installer described in the link I left named nvidia-inst
If you want to install nvidia drivers instead of nouveau use nvida-inst instead.

nvidia-inst -t

This does a test run to see if the install is successful without changing anything.
Actually, running nvidia-inst -t might end up being a good troubleshooting test in case somehow nouveau and Nvidia drivers got installed.

Pudge

Hi, thank you for your suggestion
Thankfully I can login to my system through the shell by pressing Alt + F2 on the flashing cursor screen.
I installed nvidia-inst through pacman and tried out your suggestion, but it gives an error " Sorry, Nvidia series ’ ’ is not supported by nvidia-inst"

Edit: I also tried to see what drivers are supported by inputting “nvidia-inst --drivers” and this came out

you can report with

inxi -Fza

Thank you! I have to copy the information here right? I’m new to this so I’m not sure.
keep in mind that I only have access to a shell environment and therefore unable to copy the information, so I booted a live USB session and used arch-chroot into my system. Take that how you will while reviewing this. (I don’t know what happened but at the start of every new subject there was a 12 written in it for example “12distro endeavouros”, I assume it has something to the with its background color. I removed all I could but some may have been overlooked)

System:
  Kernel 5.17.1-arch1-1 arch x86_64 bits 64 compiler gcc v 11.2.0
    parameters initrd=\arch\boot\intel-ucode.img initrd=\arch\boot\amd-ucode.img
    initrd=\arch\boot\x86_64\initramfs-linux.img archisobasedir=arch archisolabel=EOS_202204
    cow_spacesize=10G module_blacklist=nvidia,nvidia_modeset,nvidia_uvm,nvidia_drm
    nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 nvme_load=yes
  Console N/A wm xfwm DM LightDM Distro EndeavourOS base Arch Linux
Machine:
  Type Desktop System Gigabyte product H110M-S2PT v N/A serial N/A
  Mobo Gigabyte model H110M-S2PT-CF serial N/A UEFI American Megatrends v F24 date 04/11/2018
CPU:
  Info model Intel Core i5-6400 socket U3E1 bits 64 type MCP arch Skylake-S family 6
    model-id 0x5E (94) stepping 3 microcode 0xEC
  Topology cpus 1x cores 4 smt <unsupported> 
cache L1 256 KiB desc d-4x32 KiB; i-4x32 KiB
    L2 1024 KiB desc 4x256 KiB L3 6 MiB desc 1x6 MiB
  Speed (MHz) avg 800 min/max 800/3300 base/boost 3100/8300 scaling 
driver intel_pstate
    governor powersave volts 1.1 V ext-clock 100 MHz cores 1. 800 2. 800 3. 800 4. 800 12bogomips 21607
  Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities
  Type itlb_multihit status KVM: VMX disabled
  Type l1tf mitigation PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type mds mitigation Clear CPU buffers; SMT disabled
  Type meltdown mitigation PTI
  Type spec_store_bypass mitigation Speculative Store Bypass disabled via prctl
  Type spectre_v1 mitigation usercopy/swapgs barriers and __user pointer sanitization
  Type spectre_v2
    mitigation Retpolines, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
  Type srbds mitigation Microcode
  Type tsx_async_abort status Not affected
Graphics:
  Device-1 NVIDIA GK107 [GeForce GT 740] vendor Gigabyte driver nouveau v kernel pcie gen 1
    speed 2.5 GT/s lanes 16 link-max gen 3 speed 8 GT/s ports 12active VGA-1
    empty DVI-D-1,DVI-D-2,HDMI-A-1 bus-ID 01:00.0 12chip-ID 10de:0fc8 class-ID 0300
  Display server X.org v 1.21.1.3 with Xwayland v 22.1.1 compositor xfwm driver X loaded N/A
    unloaded modesetting alternate fbdev,nouveau,nv,vesa gpu nouveau note  X driver n/a
    display-ID :0.0
  Monitor-1 VGA-1 model LG (GoldStar) W1941 12serial <filter> built 2009 12res 1360x768 dpi 85
    gamma 1.2 size 406x229mm (15.98x9.02") diag 466mm (18.4") ratio 16:9 modes max 1360x768
    min 720x400
  Message GL data unavailable for root.
Audio:
  Device-1 Intel 100 Series/C230 Series Family HD Audio vendor Gigabyte driver snd_hda_intel
    v kernel bus-ID 00:1f.3 chip-ID 8086:a170 class-ID 0403
  Device-2 NVIDIA GK107 HDMI Audio vendor Gigabyte driver snd_hda_intel v kernel pcie gen 1
    speed 2.5 GT/s lanes 16 link-max 12gen 3 speed 8 GT/s bus-ID 01:00.1 chip-ID 10de:0e1b
    class-ID 0403
  Sound Server-1 ALSA v k5.17.1-arch1-1 12running yes
  Sound Server-2 PulseAudio v 15.0 12running no
  Sound Server-3 PipeWire v 0.3.50 12running yes
Network:
  Device-1 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor Gigabyte driver r8169
    v kernel 12pcie gen 1 speed 2.5 GT/s 12lanes 1 port d000 bus-ID 02:00.0 chip-ID 10ec:8168
    class-ID 0200
  IF enp2s0 state up speed 100 Mbps duplex full mac <filter>
Drives:
  Local Storage total 495.45 GiB used 58.2 GiB (11.7%)
  ID-1 /dev/sda maj-min 8:0 vendor Western Digital model WD5000AADS-00S9B0 family Caviar Green
    size 465.76 GiB block-size physical 512 B logical 512 B sata 2.6 speed 3.0 Gb/s type N/A
    serial <filter> rev 0A01 temp 34 C scheme GPT
  SMART yes state enabled health PASSED on 3y 345d 2h cycles 8139
  ID-2 /dev/sdb maj-min 8:16 type USB model USB Flash Disk size 29.69 GiB block-size
    physical 512 B logical 512 B type SSD serial <filter> rev 8.07 scheme MBR
  SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1 / raw-size 39.71 GiB 12size 38.79 GiB (97.68%) used 7.47 GiB (19.3%) fs ext4
    block-size 4096 B dev /dev/sda2 maj-min 8:2
  ID-2 /boot/efi raw-size 512 MiB size 511 MiB (99.80%) used 440 KiB (0.1%) 
fs vfat
    block-size 512 B dev /dev/sda1 maj-min 8:1
  ID-3 /home raw-size 417.56 GiB size 409.93 GiB (98.17%) used 50.73 GiB (12.4%) fs ext4
    block-size 4096 B 12dev /dev/sda3 maj-min 8:3
Swap:
  Alert No swap data was found.
Sensors:
  System Temperatures cpu 29.8 C mobo 27.8 C gpu nouveau temp 36.0 C
  Fan Speeds (RPM) N/A gpu nouveau fan 1170
Info:
  Processes 171 Uptime 12m wakeups 0 Memory 7.72 GiB used 781.2 MiB (9.9%) Init systemd v 250
  tool systemctl Compilers gcc 11.2.0 Packages pacman 923 lib 279 Client Unknown Client: systemd
  inxi 3.3.15

Series 390 should be supported for this card. 0fc8
nvidia-inst 390.ids contain this model… :thinking:
Something seems wrong…

Since this is a new installation and it had succeeded on first boot, I suggest you re-install. You have probably created this problem with some package installation or configuration before booting after a system update. You should not install new packages (especially from AUR), after a complete system update (especially the first one after installation) without rebooting first.

It might be possible to fix the system without re-installing, but it doesn’t worth the time and effort, IMHO. :person_shrugging:

2 Likes

Thanks, I think I’ll try that. I have nothing to lose anyway. I’ll make sure to update with pacman before I do anything else. Is that fine?

1 Like

and reboot after this first update! That is very important.

Very well

1 Like

Good News…maybe
I did what you suggested, I updated the system and rebooted. Then I decided to reboot after every package I installed, to try to narrow down the reason this happens and I am a hundred percent certain the AUR steam package is the culprit. well at least the nvidia-utils provider version. I suspect it all does tie back to the video driver, but I’m not sure why it happens.

Your nvidia card is supported by the 390 drivers.

Architecture Kepler
Codename GK107

hmm shouldn’t it be supported by 470xx too?

2022-04-25_20-40

1 Like

blank screen

I´m sorry but I couldn´t resist.
i hope you get the (other) problem solved soon :wink:

2 Likes