EndeavourOS Failed to Create Partition Table

I’m slightly newer to Linux/Unix in general, had Kali and wanted to switch back to an arch-based system. I went through the offline installation (I had no idea how to do the network stuff, wasn’t reading my network) and got to the install part.

When I got to the partitions, I chose erase disk, swap with no hibernate. Right away it gave me the error “The installer failed to create a partition table on Dead-vg” with "Create new partition table (type:gpt) on ‘dev/Dead-vg’

For extra info, not sure if necessary, but whenever I have my boot drive inserted, I’m unable to go into my BIOS (black screen, underscore), but I can go into the BIOS boot menu. When it’s not inserted, everything works fine.

Before launching the installer, use gparted or kde partition manager to put a clean partition table on the disk. Then launch the installer.

It sounds like the installer is tripping over your old lvm install.

1 Like

How exactly do I go about doing that? I’m still fairly new and I don’t want to accidentally screw anything up. Does this mean formatting all 3 partitions? And if so, idk about the file systems.

In the welcome application, click to launch kde partition manager.

Select the disk you want to erase. Then select “New Partition Table” from the “Device” menu.

This will essentially erase the disk so be sure to select the correct disk if you have more than one.

“New Partition Table” is greyed out with the one partition locked

Did you reboot after trying to run the installer? If the disk is mounted, it won’t let you do that.

It’s staying locked and/or possibly mounted even with reboot. I’m booting from my usb, not touching anything or mounting it

Are you sure you have hard disk selected and not the usb device?

Positive. The USB is Cruzer Blade and the disk selected is KINGSTON, which has my 2 other partitions on it that I’m able to remove. I may have messed up my kali install earlier, that may be a possibility.

Can you share a screenshot?

I’m unable to send a screenshot or remote in due to lack of experience, so here’s a pic from my phone

I’m also unable to do anything when I select it on devices

Haha…partition manager is doing the same thing. It is mounting the lvm volume group.

Click on dead-vg on the left and delete that volume group.

1 Like

Oh shit! That did it

One more thing, do you know why I’m unable to open the BIOS menu when the USB’s inserted?

No, that is pretty strange.

Yeah, now after successful installation, I’m unable to open my BIOS menu

Gonna open another post

Occasionally on an install the os loads so fast it is hard to press [F12], (its what I press to get to bios on my computer,) before the os takes over. In that case I usually start pressing over and over very soon after I turn on the computer.

Disable “Fast Boot” in BIOS and that will slow it down.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.