Endeavouros error installation

<div><strong>&lt;class 'FileNotFoundError'&gt;</strong></div><div>[Errno 2] 
		 No such file or directory: '/tmp/calamares-root-fsibbfln/efi/loader/loader.conf'</div><div><br/>Traceback:</div><div><pre>File &quot;/usr/lib/calamares/modules/bootloader/main.py&quot;, 
		 line 898, in runprepare_bootloader(fw_type)File &quot;/usr/lib/calamares/modules/bootloader/main.py&quot;, 
		 line 863, in prepare_bootloaderinstall_systemd_boot(efi_directory)File &quot;/usr/lib/calamares/modules/bootloader/main.py&quot;,
		 line 533, in install_systemd_bootcreate_loader(loader_path, installation_root_path)File &quot;/usr/lib/calamares/modules/bootloader/main.py&quot;, 
		 line 258, in create_loaderwith open(loader_path, 'w') as loader_file:^^^^^^^^^^^^^^^^^^^^^^</pre></div>

I install with windows 10 an unoccupied place . ventoy on usb.for some reason, in automatic mode, efi wants to be on a flash drive (dev sdb), I tried to change the flash drive to new, but on the last page it still writes efi on the flash drive. after this error I did the manual I created a 1 GB efi partition with the boot flag and efi mounting, created an ext4 mount in \ and the boot flag. now in uefi I have 2 windows boot manager and 1 Linux boot manager in which you can select endeavour and Windows, that is, 3 ways to launch Windows. but it turned out that this is not all, after launching the endover, I am shown a black and white kde screensaver, after which the kde window appears with its version and with the endover icon and I lose the ability to do anything and the mouse does not move but the cursor is there. I rebooted the computer and started the endover, but now there is not even this window and just a black screen and a cursor that does not move. during installation, I removed the check marks in the kde: blue, wallet-pm , printer-manager,cdekonect.I have 1hdd and I have a disk C with windows and a disk D with ntfs for games and unallocated space that I made to install Linux. and I noticed that when I want to install an endover on an unoccupied space, the situation is like this. but when I choose to install the endover on disk d, it starts to show that the efi will be on this hard disk.and for some reason, andover wants to install intel microcode for me along with amd, although I have amd, I wanted to remove it, but it says do not remove it if you do not know what to do and I did not remove it

The error you are receiving usually indicates you did something wrong in manual partitioning.

Without logs it is hard to say what exactly.

The installer should remove the microcode package you don’t use. You can leave that selection alone or uncheck the one you don’t need. It won’t matter either way.

1 Like


could be it wrongly try to use that, but you still should be able to change to create a new ESP (efi partition)

And there is only an option to replace a partition. Not to install on empty space in automatic partitioning screen.

In case you are better with manual partition creating a 1GB fat32 partition flagged as boot mounted as /efi (systemd-boot default) and /boot/efi if using grub bootloader. Set minimal a root partition formatted as ext4 mountpoint set to /

yes, by automatic, I mean replace partition

in case it is an issue if you go replace empty space instead of replacing an actual partition…
Still not really clear to my what exactly is causing your issue…

I think this is a mistake because there is no place to create a boot partition, because the program gives space only to Linux and does not give space to booter

as i said … you can create an empty placeholder partition on empty space before starting the installer… and with this you can use replace and it will create your ESP just fine.
Or do manual partition…

can you report

inxi -Fza
sudo parted -l