Endeavouros does not recognize Garuda


The Grub on Endeavouros does not recognize Garuda while the latter does, how can I fix this issue, thanks for your instructions.

[root@alnone-inspiron3583 ~]# LANG=C grub-install
Installing for x86_64-efi platform.
Installation finished. No error reported.
[root@alnone-inspiron3583 ~]# LANG=C grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found background: /usr/share/endeavouros/splash.png
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found MX 23.2 Libretto (23.2) on /dev/nvme0n1p4
Found Linux Mint 21.3 Virginia (21.3) on /dev/nvme0n1p5
Adding boot menu entry for UEFI Firmware Settings ...
[root@alnone-inspiron3583 ~]#

You had asked the same question before and had it answered already:


No, I have four distros installed that I am testing and some give me problems in the recognition of the others in the Grub, and as I am not knowledgeable in these matters I wonder if it will be a serious problem to consider to take into account, to evaluate in the end by which systems to decide to keep … – … and some examples I could give to you are going outside the Endeavouros environment, for example, Xubuntu, also btrfs, is not recognized, not by garuda nor by Endeavouros, and it’s not even in the BIOS so others …

At the end i just want to keep one Arch and one Debian.

Anyway thank you very much for your comments.


Sorry i forgot:

[alnone@alnone-inspiron3583 ~]$ inxi -Fxxx
  Host: alnone-inspiron3583 Kernel: 6.8.2-arch2-1 arch: x86_64 bits: 64
    compiler: gcc v: 13.2.1 clocksource: tsc
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: xfce4-screensaver vt: 7 dm: LightDM v: 1.32.0
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 3583 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0WHCP7 v: A00 serial: <superuser required> part-nu: 08CA
    uuid: <superuser required> UEFI: Dell v: 1.5.1 date: 05/30/2019
  ID-1: BAT0 charge: 39.9 Wh (100.0%) condition: 39.9/42.0 Wh (95.0%)
    volts: 12.7 min: 11.4 model: SMP DELL VM73283 type: Li-poly serial: 18736
    status: full
  Info: quad core model: Intel Core i5-8265U bits: 64 type: MT MCP
    smt: enabled arch: Comet/Whiskey Lake note: check rev: C cache: L1: 256 KiB
    L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 550 high: 800 min/max: 400/3900 cores: 1: 800 2: 400
    3: 800 4: 400 5: 400 6: 400 7: 400 8: 800 bogomips: 28808
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Dell
    driver: i915 v: kernel arch: Gen-9.5 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: Realtek Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-6:3 chip-ID: 0bda:5520 class-ID: 0e02
    serial: 200901010001
  Display: x11 server: X.Org v: 21.1.11 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: AU Optronics 0x10ec res: 1366x768 hz: 60 dpi: 101
    size: 344x193mm (13.54x7.6") diag: 394mm (15.5") modes: 1366x768
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.3-arch1.2
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 620 (WHL
    GT2) device-ID: 8086:3ea0
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9dc8
    class-ID: 0403
  API: ALSA v: k6.8.2-arch2-1 status: kernel-api
  Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 01:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: d8:d0:90:46:9d:0f
  Local Storage: total: 238.47 GiB used: 11.82 GiB (5.0%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 NVMe WDC 256GB
    size: 238.47 GiB speed: 15.8 Gb/s lanes: 2 tech: SSD serial: 191939446503
    fw-rev: 20200012 temp: 44.9 C scheme: GPT
  ID-1: / size: 28.84 GiB used: 11.61 GiB (40.3%) fs: ext4 dev: /dev/nvme0n1p6
  ID-2: /boot/efi size: 1.43 GiB used: 210.7 MiB (14.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 1.42 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p2
  System Temperatures: cpu: 39.0 C pch: 36.0 C mobo: 33.0 C
  Fan Speeds (rpm): cpu: 0
  Memory: total: 8 GiB available: 7.63 GiB used: 1.96 GiB (25.7%)
  Processes: 249 Power: uptime: 1h 28m states: freeze,mem,disk suspend: deep
    wakeups: 0 hibernate: platform Init: systemd v: 255 default: graphical
  Packages: pm: pacman pkgs: 1112 Compilers: clang: 17.0.6 gcc: 13.2.1
    Shell: Bash v: 5.2.26 running-in: xfce4-terminal inxi: 3.3.33
[alnone@alnone-inspiron3583 ~]$

You were told what to do in the link provided. It looks like you did that but your just not satisfied with the answer you got.

1 Like

… and as I am not knowledgeable in these matters

that is why I wonder if it will be a serious problem because i’m not satisfied with my actual “understanding” of these matters, is out of my reach.


It’s probably worth going back to basics here given your confusion. Multi-booting is not designed or intended to be universal, simple, or universally compatible. When you get to the point of wanting more than dual booting, and you don’t want a ton of problems, you are ‘most often’ better off using a virtual machine environment like gnome-boxes, virt-manager, virtualbox for your plethora of diverse OSes.

Having said that, it is still possible to have a machine setup to run multi-boot. It is simply your responsibility to tough it out and get it right. You will have compatibility issues across distros and OSes that you, personally, will need to both understand and deal with. In order to get help, you really need to be concise in understanding and communicating your environment, errors, etc. And when people get ticked off because you make them re-plow the same ground over and over, well you get to add that to your learning process. Do not expect that others will solve your problems for you.

Linux is about choice, variety, diversity, learning, and self-reliance.


maybe you should do some reading in your spare time. There are tons of resources out there to help educate you on these matters. Here are two websites I recommend you keep in your bookmarks.

  1. Arch Wiki - https://wiki.archlinux.org/
  2. EndeavourOS Wiki - https://discovery.endeavouros.com/

the first is a must for Arch based systems and the second is our own wiki with lots of good articles


As many have said above the name “dual boot” explains a lot. If you’re just experimenting with other distros best virtualize them. If you use 2 main distros Garuda and Windows for example then dual boot those two and use a hypervisor (virtualization software) to install and test others.

Garuda is a highly customized distro and I think it uses BTRFS as its default file system. Endeavour uses EXT4 by default but has the option to use BTRFS. I think this difference between the file system might be causing your problem.

But you already have received the answer to this issue. But if you want to still use more than 2 distros then it would be up to you to get it figured out. But I would advice you to look into using a virtual machine to check out other distros.

The no-brainer solution would be just make whatever Grub is detecting all your distros the default for your boot routine, however I assume you have some compelling reason for wanting to use another Grub instead.

To detect Garuda Linux you will need to install os-prober-btrfs.

yay -S os-prober-btrfs

Make sure GRUB_DISABLE_OS_PROBER=false is uncommented in /etc/default/grub. Then regenerate the Grub config.

sudo grub-mkconfig -o /boot/grub/grub.cfg
1 Like

A similar solution was already presented to OP in their previous thread on the same issue of Grub and multibooting.

Back then, they choose not to implement it and went for the “no-brainer” solution of letting Garuda’s grub to be in charge.


You can lead a horse to water, but you can’t make them drink.


I recall a thread where I practically “chewed” everything and put it into the mouth of op. They just had to swallow.

Then when the problem was solved, they marked their own post “It works!” as solution.

When I asked why, they said: “Because it was I myself who put the commands into the terminal”.



In case you want to try multi boot:

Well I have learned something, that some of you simply do not listen, you do not put yourself in the place of the speaker because I have not said that I do not read or seek information, but that the understanding of certain issues are beyond my understanding, I have no training in computer science, no solid foundation of any type and I have thrown myself into something that goes beyond my ability; but it is good to hear you to say all what you have said because you have confirmed now to me that both systems, this one and Garuda, are definitely out of my reach and that the best thing to do it is to uninstall, – so I appreciate the adverse comments and the positive ones that were giving here to me by some of you; the commands did not work …

It’s unfortunate that you interpret certain comments here as being “adverse”.

You say yourself that:

Creating a multiboot system (in your case 4 systems) with different filesystems and all with their own grub and os-prober which possibly handle things differently is something that can give headache to more experienced users as well.

I tried myself to help you out in your previous thread about the same issue to solve it. You seemed to be content with the solution in that thread and marked it even as solved in the title and not checking the solution box under the relevant post leading to the solution.

Why not, as has been suggested, just starting off with only one system. One which is within your reach.
Then take your time to get to know your system, its basic structure, bootloader, filesystem etc.

You could create virtual machines for trying out other systems as well.

When you think you have enough understanding and skills, then you could experiment with dualbooting.

After you get hang of it perhaps you could adventure with a third system and so on.

I wish you all the best on your Linux journey.

1 Like

We all need to start somewhere. I would recommend single boot more than anything. I think multi boot is one of the most difficult things you can do.

It took me years to figure out dual. I’ve never tried more lol.

Well, don’t know what you mean by.

I think we have. Or you’re not clear on what you want to do.

Contributors have provided you with an answer in the previous post. But you have come back with the same issue.

In one of your replies.

As most here said it must be some file system issue preventing :enos: from being recovered.

And you were just experimenting.

The best option would have been to use a VM.

As you say you’re very new to Linux. I recommend you go with a Debian-based distro like Linux Mint or MX Linux. They are rock solid and Mint kind of holds your hand for some time.

When you understand how most concepts about Linux you can make the switch to an Arch-based distro.

No need to be upset or aggressive here. We all are here to help but when someone kind of refuses to acknowledge a provided solution people tend to turn away.

Anyway, hope you learned something new, and good luck in your future distro adventures.

P.S: Best to leave this here everyone we’re not that type of a community.

1 Like

In modern UEFI systems, there is already a native multi-boot functionality, provided by the firmware.
It is a Quick Boot menu, which can be shown with a hotkey while the computer starts (info in motherboard/laptop User Guide).
It is the simplest, easiest and most reliable way to use multiple operating systems on a single PC.

Grub is not necessary for multi-booting, unless you want to learn how grub works, or you want to customize the boot menu appearance (colors etc.).