EndeavourOS displaylink stopped working

Hi All,

I am running EndeavourOS with displaylink and for some reason it stopped working yesterday.

Here is what I am running:
OS: EndeavourOS Linux x86_64
Kernel: 6.4.10-arch1-1
Resolution: 1920x1080
DE: Plasma 5.27.7
WM: KWin
CPU: Intel i7-7700HQ (8) @ 3.800GHz
GPU: AMD ATI Radeon RX 470/480/570/570X/580/580X/590

When I check the service it is running:

sudo systemctl status displaylink.service

● displaylink.service - DisplayLink Manager Service
Loaded: loaded (/usr/lib/systemd/system/displaylink.service; enabled; preset: disabled)
Active: active (running) since Sat 2023-08-12 07:54:24 CDT; 12min ago
Process: 3121 ExecStartPre=/sbin/modprobe evdi (code=exited, status=0/SUCCESS)
Main PID: 3124 (DisplayLinkMana)
Tasks: 9 (limit: 14266)
Memory: 5.5M
CPU: 71ms
CGroup: /system.slice/displaylink.service
└─3124 /usr/lib/displaylink/DisplayLinkManager
Aug 12 07:54:24 bismal-abyss systemd[1]: Starting DisplayLink Manager Service…
Aug 12 07:54:24 bismal-abyss systemd[1]: Started DisplayLink Manager Service.

When i run xrandr I get the following output:

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 381mm x 214mm
1920x1080 60.01*+ 40.00
1680x1050 60.01
1280x1024 60.01
1440x900 60.01
1280x800 60.01
1280x720 60.01
1024x768 60.01
800x600 60.01
640x480 60.01
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 disconnected (normal left inverted right x axis y axis)

And it is only showing this when I do a listproviders:

$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x58 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 6 outputs: 4 associated providers: 0 name:AMD Radeon RX 580 Series @ pci:0000:01:00.0

I have tried going back to the beta drivers and still not working. Has anybody else ran it to this?

There was an update to evdi a few days ago.

See if this can help you:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.