Endeavouros did not reboot or shutdown (watchdog0 did not restart - SP5000 TCO)r

Hello everybody,

Here is the issue while rebooting:

i m facing a weird issue. The last row that appears is that the system has umounted all the filesystems and swap saying “Rebooting”… i don’t get out of there, systems doesn’t reboot or shutdown.

I didn’t run endeavouros per months. I did update yesterday, had to chroot to repair grub, also fixed a not synching pacman issue, and never faced an issue like this.

I have followed this advice: New install with new Radeon 7800XT, PC won't shutdown fully or restart - #4 by ricklinux and blacklisted the SP5000 but didn’t work.

My config is a b550 itx asus, 5800x3d and a 6900xt. I did update the bios with the last one like 1 month ago, and i disabled the ftpm option that gave me stutter in many games.

To another disk there is windows 10 installed.

I did a fresh install of endeavouros - i dunno why, sorry i m stupid i just wanted to try to get rid of it - and… same damnd issue.
Previously i used endeavouros for like 1 year, updating the system and not getting any issue.

Did anyone else faced the same issue lastly?

Thx in advance

Here is a thread where two other users report having similar issue.

This is thread from Arch Forum.

The OP reports that disabling Bluetooth or downgrading the kernel one version back resloves the issue.


Might be related to: https://bugzilla.kernel.org/show_bug.cgi?id=218651

first of all thank you for the referring topics

i suspected was something related to the kernel, or something in the kernetl

yes i have I225-V buggy ethernet lan that doesn’t work well on windows 10, frequently disconnecting, and the ax200 wifi and bt… so i won the bingo of the bad things…

ok the good news that its is not something that is dying in my pc… i hate use windows, so at this point i have to downgrade the kernel

ohhh i ll try first to disable bt via bios

It has this in my boot log. Disabling WiFi/BT did not solve the problem.

How did you disable Bluetooth?

The post in Arch forums says you would need to disable it in the firmware settings.

Nah, I disabled in the KDE’s menu. So, that’s probably why it still gets stuck.


If there is nowhere in the firmware settings you could disable the Bluetooth, see if blacklisting its module/driver at the kernel level would help.

Please refer to ArchWiki about how to blacklist a kernel module.

Can’t EndeavourOS allow choosing “LTS” kernel versions like Manjaro? I think there are too many kernel updates. It’s not that I want to update kernel, but it gets updated with other things every time. I guess some users like using the latest kernel as soon as it gets released, but from my experience, I usually get more troubles than benefits from frequent kernel updates.

i disabled BT and WIFI from the bios, didn’t work

so i re-enabled both

i tried to reinstall the kernel giving pacman -Syu linux and watchdog0 did not stop error, disappeared

and wifi started to work in linux… i didn’t notice that the wifi icon was missing in the bar

but still pc gets stuck when i try to reboot the system

other info: i m using ext4 for the /root partition, and btrfs (from previous install) in the home partition that i didn’t format

You can have both installed, the latest stable and the latest LTS. No problem.

yes i remember with manjaro there was a kernel tool that allowed to you to choose the kernel that you wanted to keep, and you could also choose to install whatever version you wanted

Seems like “Sleep” does not work either.

To install more kernel and to choose one at boot, just install (if not yet present) and run akm (Arch Kernel Manager) from the endeavouros repository.

thank you i v totally forgot that tool

I had thought that a fix would be released very soon, since this is a serious bug, but it seemed it wouldn’t come fast and not being able to put the PC to sleep was too inconvenient, so I disabled BT using the following method. Now restart/sleep works fine.

Create file: sudo micro /etc/modprobe.d/blacklist.conf
blacklist bluetooth
blacklist btusb

Do you mean this? https://bugzilla.kernel.org/show_bug.cgi?id=218651#c14

tried the kernel lts but same at the reboot… i had to hard reset several times, and for the moment i decided to remove the disk with endeavouros

i m not sure it is the same bug that prevent my pc to reboot correctly, but for sure there is a bt and wifi issue

i also have a intel nuc with an old skylake i5, and endeavours with gnome runs fine

when i reboot the nuc i see the message from watchdog0 but it reboots fast

i didn’t update yet my 2 thinkpads (x230 and x270), where i have endeavouros with gnome… soon or later i must update them and hope they will run well

If I understood this, the bug has been fixed on kernel v6.8.3.

Today I updated the system and now it is on 6.8.4-arch1-1.

However, the issue still remains on my side.

After updating and rebooting, I rebooted three more times. The first two were nominal, but the third freeze.

Can you help me debug this? What commands should I run to get more info?