Endeavouros.db connection timeout

I’m unsure in what section to post this really, hopefully it’s okay here.

When running yay, I get the following error message:
error: failed retrieving file 'endeavouros.db' from ca.gate.endeavouros.com : Connection timeout after 10000 ms

This is the entire terminal output:

❯ yay
[sudo] password for smokus: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community                                     6,7 MiB  3,83 MiB/s 00:02 [----------------------------------------] 100%
 multilib is up to date
 endeavouros is up to date
error: failed retrieving file 'endeavouros.db' from ca.gate.endeavouros.com : Connection timeout after 10000 ms
:: Starting full system upgrade...
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
 -> Flagged Out Of Date AUR Packages:  libreoffice-extension-languagetool
 there is nothing to do

Can I do something about it or simply wait it out?
It has never happened before.

1 Like

Refresh mirrorlist from welcome app.

I have already, but it hadn’t helped.

Try forcimg specific countries with reflector ie.

sudo reflector --country=Germany --latest 10 --sort rate --save=/etc/pacman.d/mirrorlist

I already forced Germany. I am in Germany even though the profile country isn’t it.

I am about to jump into a meeting so can’t be more helpful but I would quickly point out that it is the EOS mirror that needs changing, not the Arch mirror.

2 Likes

Same problem here:

Try to run

eos-rankmirrors

and then save the new mirrorlist. Probably there is an issue with that particular :enos: mirror

7 Likes

This has actually worked. Thanks!

When you install EOS, will it automatically rank mirrors (for both, Arch and EOS) or does the user need to do this manually?
(reason for asking: It’s always the first mirror in your mirror-list that is being utilized by pacman (unless that one “fails” and the next one is used). Assuming that a lot of users do not do this, it will put a big burden on ca.gate.endeavouros.com since that is the first one in the “default” list…)

As far as I know, it doesn’t do it automatically. Users have to do it manually using reflector-simple.
Additionally, there should be an option to rank eos-mirrors when eos-mirrorlist is updated.

1 Like

Currently Arch mirrors will be ranked, but EOS mirrors not.
Looks like it is now missing after some mirror changes, so we need to make this change as well.

2 Likes

I updated my system (sudo pacman -Syyu) on July 28, 2022 and not problem updating. But then I rean the same update command on July 30, 2022 and I was able to replicate the same error reported abobe.

As recommainded I ran " eos-rankmirrors" and the problem was fixed.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.