EndeavourOS correctly identifies Bluetooth keyboard, successfully connects to it, but does not receive inputs from it

The problem here is that EndeavourOS is able to correctly identify that my BT keyboard is a keyboard, but for some reason, upon a successful connection, it is unable to receive inputs from it. xinput list for instance does not list the keyboard at all even though it lists my phone which is connected via Bluetooth.
Things I’ve tried:

  • I’ve switched the input mode of the keyboard and tried all modes (Windows/iOS/Mac)
  • I’ve tried all the function keys on the keyboard to see if it changes a keyboard setting
  • I’ve tried turning the keyboard on and off
  • I’ve tried turning PC Bluetooth on and off
  • Forgot to mention in earlier versions of this post that I did also try re-registering the keyboard onto my PC

None of those actions worked.

Important Notes:

  • Prior to an EndeavourOS update (I don’t know which one as I wasn’t looking when updating), this device worked perfectly
  • The keyboard device works perfectly on all other devices
  • As I don’t know which update was the last update that worked, I can’t just simply downgrade my Bluetooth software
  • Bluetooth status displays: [time] [username] bluetoothd[685]: profiles/input/device.c:ioctl_is_connected() Can't get HIDP connection info
    [time] [username] bluetoothd[685]: profiles/input/device.c:hidp_add_connection() Rejected connection from !bonded device /org/bluez/hci0/dev_24_02_86_33_C4_08

Thanks in advance for any help I receive.

what does
bluetoothctl devices display?

I do see the device there: Device 24:02:86:33:C4:08 SANWA BT KEYBOARD
(Just confirmed once again.)

never mind i saw that you stated it was working before.

Personally i would use bluetoothctl and remove the device and go through the whole process …every step to scan, pair, connect, trust etc… and see if that gets it working.

2 Likes

So your solution actually worked. I am actually typing on the BT keyboard right now as we speak.
The key is that I had to manually do all of that through the terminal emulator. Thank you so much!

Bluetooth can be fin achy and this is always the best method because sometimes it tries to connect and use the incorrect hardware info. Then it doesn’t work even if it shows connected.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.