EndeavourOS Cassini with dracut does not configure hibernation

Hi

I tested the new EndeavourOS Cassini on a virtual machine because I wanted to start experimenting with dracut, which is now replacing mkinitcpio (for good, I seem to understand) in EndeavourOS.

When partitioning, I selected to wipe the whole disk and “swap with hibernate”, which used to work in the past (with mkinitcpio).

However, I seem to understand that now EndeavourOS, while configuring fstab and /etc/default/grub correctly for hibernation, forgot to configure dracut accordingly. As a result, hibernation does not work.

Is that intentional or a bug?

1 Like

I would have to do some testing to see what is going on but it definitely isn’t intentional.

Hi, do we know what’s going on about hibernation/dracut ?
Is there any solution or workaround ? Does this issue happen with both swapfile and swap partition ?

Thanks

I have not had time to investigate this reported issue yet due to the holidays.

Alright, thanks, i will wait a little bit before to install Cassini.
Could you please let me know if you have some more inputs ?

1 Like

I didn’t want to generate panic :wink:

The installation already sets up most of the things for hibernation (if you choose swap with hibernate). The only missing part is the dracut part.

It’s easy to fix that:

first generate the dracut configuration file for hibernation:

cat <<-EOF | sudo tee /etc/dracut.conf.d/resume.conf
add_dracutmodules+=" resume "
EOF

and regenerate initramfs

sudo dracut-rebuild

And reboot.

IMPORTANT: the above instructions assume that the other configuration parts for hibernation are already in place: SWAP partition in /etc/fstab and the correct resume option in /etc/default/grub.

As I said, the above two steps are implemented by the installation if you selected swap partition with hibernate.

Otherwise, if you did not select that option, you’ll have to perform a few additional steps. I summarized them here: https://www.lorenzobettini.it/2022/12/enabling-hibernation-in-endeavouros/

Hope it helps.

10 Likes

For any who uses dracut and systemd-boot
if you want to edit boot entry options (add resume uuid, resume-offset), then edit this file: /etc/kernel/cmdline
Then run: sudo reinstall-kernels

Dear lorebett,

first of all I thank you for this topic and the elaborated work-around.
I am not quite sure if my concern fits to your. It is this:

Context_
Seven days after the release of the 2022-12-19 EndeavourOS Cassini Iso release I installed with the older 2022-09 iso release and all worked well just as on my other machine. One day later though it came to my knowledge, that Cassini has just been released. So I thought, well if there is one newer iso -which was in parts improved - I will take this one to install EOSCassini on two more machine, knowing that this would not be necesary.

Observation_
Two things showed themself up after the installing of Cassini GNOME:
1_ GDM does not have Adwaita Icons. It looks rather like the Qogir Icons are installed by default. After logging in the chosen Adwaita Icons show up. I am aware that this is only “cosmetiques” not really important but not reasonably.
2_This now is the important part which seems to relate to your topic.
I installed GNOME with full-disc-encrytion and swap (with hibernation) partition. Now every shutdown - reboot or shutdown - this message appeares:

[1696.460166] systemd-shutdown [1] waiting for process: 482 (brltty)

And with this message it take to my mind far too long to shutdown.
Compared with the installation with the older iso, this message does not show itself up and the system shuts quickly down.

Question_
Dear lorebett: Is your workaround suited for this fact - I mean number 2_ of mine? Would it lead to a quick shutting down? I am kindly asking this, although I am experienced, I am cautious with configuring the system on this deep level. I would preciate an answer. Thank you very much in advance.

Sorry but I never used disk encryption… IIRC encryption might require some further adjustment to dracut as well…

I am not an expert on GDM but I don’t think it inherits gnome theming and icons.

I don’t think that has anything to do with what is in this post. Do you need the brltty? If not, you can just uninstall it.

Thank you for your quick reply.

I came across this thread 3-4 days ago. Thanks for the thorough guide @lorebett, I managed to get hibernation working on my machine. And thank you @boydaihungst for the systemd-boot addendum! :slight_smile:

2 Likes

to 1_ SOLVED
Reason was the following file, which does NOT exist in Cassini installed with the 2022-09 iso:
99_endeavouros-gnome.gschema.override

[org.gnome.desktop.interface]
color-scheme=‘default’
cursor-theme=‘Qogir’
gtk-theme=‘Adwaita’
icon-theme=‘Qogir’

workaround

install from the aur-repository:
a_ yay gdm-tools
b_ yay gdm-setting

open gdm-settings
a_ set cursor-theme
b_ set icon-theme
c_ save settings and logout

gdm settings now set as chosen

to 2_ NOT solved
I executed command
sudo pacman -Rns orca [because of dependencies] brltty
The problem still remains and brltty delays shutting down.
Any further idea? What is with dracut?

That is a known issue with the brltty module. https://wiki.archlinux.org/title/Dracut#A_stop_job_is_running_for_"brltty"

My understanding is uninstalling brltty should resolve the issue, but you will have to regenerate the initramfs again afterward. Did you try that?

Your other option is to exclude the module in a dracut config file.

omit_dracutmodules+=" brltty "

Did you rebuild your initrams and reboot?

If you are using grub you can do that with sudo dracut-rebuild, if you are using systemd-boot, call sudo reinstall-kernels

1 Like

SOLVED

I added
omit_dracutmodules+=" brltty "
to
/etc/dracut.conf.d/eos-defaults.conf
so it now reads

omit_dracutmodules+=" brltty "
omit_dracutmodules+=" network "
compress=“zstd”

Thank you for your impulse.

Yes, I did it in the first place, resp. the system. But I did it once again - with no change to the prolem.
The option mentioned above by BluishHumility SOLVED the problem at last.
Thank you so much for your endurance in this matter.

brltty =

extra/brltty 6.5-3 (1.8 MiB 9.3 MiB) 
    Braille display driver for Linux/Unix

That’s not installed by default and only getting in from installer ISO if you do select option to install tools for impaired vision.
If you do not need this and installed it accidentally remove the packages and rebuild the kernel images.

sudo pacman -Rc brltty
sudo dracut-rebuild

If you do rebuild the images keep in mind that you need to reboot / power of after this to get the new image loaded … for the shutdown directly after rebuilding images it will still show the brltty warning/ lag …

Do not select this:

Same for the fixes for Gnome untag them and you will get unchanged unfixed Gnome:

dear doktor,
thank you so much for this excellent workaround of the problem.
due to private challenges this delayed reply.
ex temporae: i gratefully thank the endeavouros and archlinux communitues for its enduring, empowering and supporting engagement.
falparsi

1 Like

10 posts were split to a new topic: Machine does not wake from hibernation