EndeavourOS boot option disappeared

EndeavourOS boot option disappeared after update to kernel 6.2.5 today (or maybe something else).
Only windows and firmware settings options are shown.
How can I repair boot from live-usb?

is it possible to boot eos from BIOS ?

No. Windows 10 on separate drive my only option (besides live usb). Tried in EFI mode and in Legacy mode.
Also tried to install rEFInd from live, it also shows only windows, BIOS and systemd-boot, which have only BIOS and windows options.

eos once was installed in systemd-boot ? or grub ?

Installed with systemd-boot, worked well through few updates

sorry, I’m not really experienced to systemd-boot.
guess the kernel is to be reinstalled but I’m not sure
– sorry, can’t help there

So, i think best option for me for now - backup home and reinstall. Cant find much existing info for the issue and need my pc for work as soon as possible.
Thanks for your time!

I had the same issue. After today’s update all my boot entries in systemd-boot went missing. I had to arch chroot and run reinstall-kernels to fix it.

So first: Arch-chroot via the EndeavourOS ISO (livesystem)
Then: sudo reinstall-kernels

I don’t know how this could happen since the hook that updates my boot entries after every kernel update worked fine so far.


@insanecake before reinstalling the OS I would try to chroot (from livesystem) and reinstall kernel, run a initbuilding like mkinitcpio -P (or dracut-rebuild, depending on what you use)

I think this is propper solution, but cant confirm due to already reinstalling EOS, sorry. (And finally remove windows installation completely)
Also this time i make install with additional lts kernel, just in case.

Will check, if face this problem in future

This won’t help.

This is the way to resolve the issue.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.