Endeavour stuck at hostname services

The endeavour os just stuck there after i updated the system using pamac-all the app manager
I am new to linux can anyone help me?
Plz and thank you

unfortunately pamac is a Manjaro product and is not supported by EndeavourOS. EndeavourOS only has a command line package manager and that is all that is supported. personally I would get rid of pamac-all and just use pacman -Syu you may need to run a live boot and chroot over to the hard disk that EndeavourOS is on and try to do a new update without the pamac

Hi thanks for taking the time to help
How ever i tried using tty3 interface and used sudo pacman -Syu it just tells me everything is uptodate i am lost and looking for solutions i tried reinstalling nvidia drivers that did not work either
Can anyone gide me inyo how to figure out what the problem is and how to fix will be much appreciated will any way fucking thins up and trying to fix them in a major part of learning any way :grin:
and thanks for the help

If you have network connection in TTY, you could run the following commands and post the URL they produce here on the forum. The log and sysinfo might give some forum mates some idea about what might be wrong on your system.

inxi -Faxxxz | eos-sendlog

journalctl -k -b -0 | eos-sendlog

Happy shooting … troubles :wink:

Good Luck!


looks indeed liek an issue with the DM not showing up… and if Nvidia was used it will in mostlikely something messed up withn the drive r… modules p.e. if using nvidia-dkms reinstall it… or remove nvidia all together and reboot into open source driver usage nvidia-inst -n

For the first command this is the out put
Https: //0x0.st/HKES.txt
2nd no output
I just hope this does help

I tried it it get’s stuck on targetin graphical interface

not really the right url i think…

could be also something like drive is full… and if it is true that you can not reach X with Nvidia and nouveau drivers in use… something else is broken…

looks similar to this: https://bbs.archlinux.org/viewtopic.php?pid=2034886#p2034886
He just ran:

sudo mkinitcpio -p linux

bad advice without knowing if user is usinhg mkinitcpio images at all.
Could be dracut (default on EndeavourOS) and in most cases a non working kernel image would lead to failed boot… here only X fails to start.

The output on the pastebin is a failed log // pastebin creation and not any system relevant log…

@joekamprad yeah fair enough.

He said he tried re-installing the nvidia drivers and that didn’t work. So lets see which nvidia he has installed.

pacman -Qs nvidia
1 Like


may help to provide more info for fatser finding issue and solving :wink: