Endeavour OS Stable

Well I have been trying to install the new stable version for over 4 hours, and nothing seems to work. I did get it installed, but when I followed the instructions to create the boot/efi partition without esp flag, I get a complaint it needs one. Gparted selects the esp flag automatically when selecting the boot flag (I tried that first and it didn’t work), but if you click it a second time, it un-selects esp and keeps only the boot flag. It was pure chance I would figure that out! Well that didn’t work either. Finally I went the rout of letting the installer setup the discs as it wants to, and it finally booted to “Endeavour Linux with Linux” and the fallback option, but neither do anything but boot to black screens (one RCA TV and one Phillips 4k monitor) no matter which one I have turned on or both. All I get is a periodic beep, and after almost 5 minutes a squished screen with a few colorful lines across (The desktop???).

I don’t have onboard graphics, only an MSI Nvidia GeForce GTX 1050.

Any clues?

I have the same problem on one of my machines also, turns out it has to do with the brand of the ssd. I’m going to research further how to make this work. I’ll keep you posted, I’m not entirely sure, but I also think Calamares has to do with this problem also, since other installers do work on that ssd.

@Bryanpwo can you both provide info on the SSD’s ? as it may lay down to continious TRIM is enabled by default on detected ssd drives from calamares, but we may can change this.

1 Like

Not sure about the other problems you mentioned, but in this case just ignore that popup message and keep installing. The issue was reported to calamares devs and i hope they fix it soon.

In the situation I have now on my machine periodic TRIM is enabled, but it isn’t running EndeavourOS at this moment, it runs Arch, now I can’t do a testrun, but I’ll do it tonight.

It’s an SK-Hynix HFS250G32TND-N1A2A (Boot and Root), and I have the swap on a PNY CS900 240GB SSD.

I did that. It did install, but again, after install and reboot I get nothing but black screens instead of login, beeps from the speaker, and just colored, scattered lines across the mid top of screen.

So the SSD is obviously not the issue there.:sob:

Can you chroot? Would you try, because when I had this I couldn’t chroot also, because the disk couldn’t be recognized, but Calamares recognized the partition strangely.

I can boot off of the drive, but I finally gave up and decided to just install Reborn, and unborn it! The reason I installed Endeavour, was because when I followed the “Antfree” instructions it hosed grub after uninstalling “Antergos-grub-theme”. Seems like it should have mentioned to change the theme first before uninstalling it. I had some other problems lately with the PC acting sluggish, so I decided to just try Endeavour.

The issue is not the drive, although it made the install somewhat of a nightmare, it’s the fact that it boots, and ends up with no graphics where the logon prompt should be.

I didn’t have that problem uninstalling the grub theme but I didn’t follow the Ante free method. I methodically removed each package by looking at them and seeing if it was strictly an Antergos package or not. I also checked if I could replace it with something from the AUR or community repos. I did 5 computers with no issues all converted to Arch only.

I didn’t expect a missing theme to make grub unbootable, after all it’s just a theme. :roll_eyes: I suspected it would just fall back to the default, or not use one at all. :face_with_monocle: Seems like the grub developers need to think about that one :thinking:, and the “AntFree” instructions should be updated to warn about that too :face_with_raised_eyebrow:.

Ya you wouldn’t think it would do that either but i think it depends on how you did the removal of everything. I didn’t follow the Ante Free way. I did it with my own methodical approach to removing the packages. I used the same method on 5 and they all went good including the grub splash screen removal. I guess sometimes you get lucky. :slightly_smiling_face:

On the first machine I removed all the antergos packages grub just complained that the theme wasn’t there and after a few seconds it showed up with the standard one.

Yes…some error messages on boot. I ran sudo grub-mkconfig -o /boot/grub/grub.cfg after removing it.

Endeavour OS Stable ISO does not boot with virtualbox

Hello, for my part no problem: download in direct link

MadMax, switch from VMSVGA to VBoxSVGA!

1 Like

Thanks, that was the solution.:+1:

for virtualbox with 3d acceleration choose VBoxVGA as graphics controller to boot into liveenvironment :wink:

1 Like

hello ,it’s VMSVGA and the 3D that bug and not VMSVGA alone