Endeavour OS Stable

Can you chroot? Would you try, because when I had this I couldn’t chroot also, because the disk couldn’t be recognized, but Calamares recognized the partition strangely.

I can boot off of the drive, but I finally gave up and decided to just install Reborn, and unborn it! The reason I installed Endeavour, was because when I followed the “Antfree” instructions it hosed grub after uninstalling “Antergos-grub-theme”. Seems like it should have mentioned to change the theme first before uninstalling it. I had some other problems lately with the PC acting sluggish, so I decided to just try Endeavour.

The issue is not the drive, although it made the install somewhat of a nightmare, it’s the fact that it boots, and ends up with no graphics where the logon prompt should be.

I didn’t have that problem uninstalling the grub theme but I didn’t follow the Ante free method. I methodically removed each package by looking at them and seeing if it was strictly an Antergos package or not. I also checked if I could replace it with something from the AUR or community repos. I did 5 computers with no issues all converted to Arch only.

I didn’t expect a missing theme to make grub unbootable, after all it’s just a theme. :roll_eyes: I suspected it would just fall back to the default, or not use one at all. :face_with_monocle: Seems like the grub developers need to think about that one :thinking:, and the “AntFree” instructions should be updated to warn about that too :face_with_raised_eyebrow:.

Ya you wouldn’t think it would do that either but i think it depends on how you did the removal of everything. I didn’t follow the Ante Free way. I did it with my own methodical approach to removing the packages. I used the same method on 5 and they all went good including the grub splash screen removal. I guess sometimes you get lucky. :slightly_smiling_face:

On the first machine I removed all the antergos packages grub just complained that the theme wasn’t there and after a few seconds it showed up with the standard one.

Yes…some error messages on boot. I ran sudo grub-mkconfig -o /boot/grub/grub.cfg after removing it.

Endeavour OS Stable ISO does not boot with virtualbox

Hello, for my part no problem: download in direct link

MadMax, switch from VMSVGA to VBoxSVGA!

1 Like

Thanks, that was the solution.:+1:

for virtualbox with 3d acceleration choose VBoxVGA as graphics controller to boot into liveenvironment :wink:

1 Like

hello ,it’s VMSVGA and the 3D that bug and not VMSVGA alone

Might be good to include this info as part of an FAQ?

Notes / Troubleshooting:

It helps to change display settings to use the older better implemented VBoxVGA as controller device in the settings.

2 Likes

sure, mostly yes, VBoxVGA is the legacy option, the new options are not working for Archlinux… and 3d mostly everyone will choose…

1 Like

Btw., at VM start in current VBox dev version 6.0.11-132749 it is warned that VBoxVGA in the upcomming VBox version 6.1 no longer supports 3D acceleration (well, 2D video acceleration doesn’t work in Linux VMs anyway).

Therefore, it makes sense to set VBoxSVGA immediately.

2 Likes

i do checking this thanks for the Info!!
but will VBox S VGA not also removed then?

Extra reset for this screenshot. :wink:

vboxvga_no_acc

1 Like

thats good i will add this to the WIKI!
done: