Endeavour OS on Razer 14 blade - Battery, Headphone Sound & Optimus help!

Hello all!

Been running Linux Cinnamon Mint on my 2019 Razer Blade 13 flawlessly for years, and recently was able to get an amazing deal on a new Razer Blade 14, with a Ryzen 5900HS+Integrated AMD, and an NVIDIA 3080ti. Here’s what worked and what didn’t, and settled on Endeavour OS+KDE as it seemed to most stable / compatible out of the box, and with the kindest community (Manjaro worked as well).

Linux Mint kept constantly rebooting after login, MXLinux didn’t sleep or make it easy for switchable graphics, and Ubuntu didn’t let me switch my screen refresh rate for some reason. However, there are a number of things leading to me considering going back to my old laptop on Mint or changing models as I can almost but not quite get Endeavour working properly on it.

Here’s what works so far and what doesn’t:

Sound through headphone jack is unusable (tinny / very low-volume / no bass / very hard to hear voices). The speakers, and a Bluetooth headset, work perfectly. I’ve tried messing around with it in Alsamixer and Pulseaudio, but no dice. However, this was true of all the distros I tried, so is not an Endeavour OS-specific problem, but if you have a direction for me to look, I’d love to sort this out.

Switchable graphics seems be working, after installing optimus-manager and the QT icon. I have it set to “hybrid” ("integrated didn’t allow the system to detect my external monitors), so I’m hoping that the NVIDIA card isn’t being used at all unless I specifically invoke with prime-run or Lutris’ prime-offloading setting. I don’t know if this is the case because my battery usage is off the charts (more on that later).

Sleep is hit-and-miss; sometimes it wakes up fine, sometimes everything seems to wake back up except for the screen.

Disabling Bluetooth means I can’t turn it on again until a reboot.

The battery life is the big issue for me at the moment, and for some reason the Arch-based distros invariably gave me 2-3 hours less (even after tweaking) than the Debian-based distros (which themselves gave me 2-3 hours less than windows.):
Windows 10: 8.5+ hours on battery
Mint & MX Linux: ~6.5 hours on battery
Endeavour & Manjaro: ~3.5-4 hours on battery

While I understand that it’s unrealistic to expect the same battery life as in Windows, I would hope to get at least 5.5 - 6 hours from the laptop, which is as long as I ever tend to spend away from a wall outlet anyways. Powertop reports an idle draw of 15-28 watts on battery, with the refresh rate down to 60hz, low brightness, all Powertop tunables set to Good, and the keyboard lighting off. Here’s my Powertop output at idle:

The battery reports a discharge rate of 18.9 W
The energy consumed was 336 J
The estimated remaining time is 1 hours, 11 minutes

Summary: 2128.6 wakeups/second,  0.0 GPU ops/seconds, 0.0 VFS ops/sec and 63.4% CPU use

                Usage       Events/s    Category       Description
              8.5 pkts/s                Device         Network interface: wlan0 (iwlwifi)
            100.0%                      Device         Radio device: btusb
            277.9 ms/s     152.2        Process        [PID 7209] /usr/lib/firefox/firefox -contentproc -child
            127.4 ms/s     352.9        Process        [PID 6199] /usr/lib/firefox/firefox --sm-client-id 1072
             50.8 ms/s      0.00        Process        [PID 8381] [kworker/0:0]
             35.0 ms/s     240.1        Process        [PID 5589] /usr/lib/Xorg -nolisten tcp -background none
              6.1 ms/s     365.8        Timer          tick_sched_timer
             17.8 ms/s     102.4        Process        [PID 5693] /usr/bin/kwin_x11 --replace
             18.1 ms/s      0.00        Process        [PID 5326] [kworker/12:2]
             11.6 ms/s     112.1        Process        [PID 7213] /usr/lib/firefox/firefox -contentproc -child
             11.2 ms/s      86.1        Process        [PID 6301] /usr/lib/firefox/firefox --sm-client-id 1072
             12.5 ms/s      57.4        Process        [PID 6210] /usr/lib/firefox/firefox --sm-client-id 1072
              9.3 ms/s      90.0        Process        [PID 6214] /usr/lib/firefox/firefox --sm-client-id 1072
              9.1 ms/s      60.2        Process        [PID 6282] /usr/lib/firefox/firefox --sm-client-id 1072
              4.9 ms/s      99.5        Interrupt      [93] amdgpu

Interesting tidbit - the device “USB device: Razer Blade (Razer)” in Arch-based distros seems to be always on, and pulling the most power of all other sources. Even enabling its autosuspend in powertop doesn’t seem to do anything.

As I’m new to this forum, please let me know if it’s better for me to split up these questions into different threads, or if I can keep it all here. Also, I’m happy to help any devs debug anything they want to test on the Blade 14 to help others.

Let’s start with the output of inxi -Fxxc0z | eos-sendlog
it will give us more to work with.


Here’s my inxi -Fxxc0z | eos-sendlog (this is plugged in, with external monitor and bluetooth devices on; let me know if I should re-run it in my battery / low-power state):

  Kernel: 6.4.10-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 dm: SDDM
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Razer product: Blade 14 - RZ09-0370 v: 1.04
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Razer model: PI411 v: 4 serial: <superuser required> UEFI: Razer
    v: 1.06 date: 06/07/2021
  ID-1: BAT0 charge: 27.0 Wh (42.9%) condition: 63.0/61.6 Wh (102.2%)
    volts: 15.6 min: 15.4 model: Razer Blade serial: <filter> status: charging
  Device-1: hidpp_battery_0 model: Logitech MX Ergo Multi-Device Trackball
    serial: <filter> charge: 55% (should be ignored) status: discharging
  Info: 5-core (4-mt/1-st) model: AMD Ryzen 9 5900HX with Radeon Graphics
    bits: 64 type: MST AMCP arch: Zen 3 rev: 0 cache: L1: 320 KiB L2: 2.5 MiB
    L3: 16 MiB
  Speed (MHz): avg: 2915 high: 3681 min/max: 1200/4889 boost: enabled cores:
    1: 3223 2: 2513 3: 3681 4: 2890 5: 3192 6: 3194 7: 2743 8: 2655 9: 2148
    bogomips: 59311
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GA104M [GeForce RTX 3080 Mobile / Max-Q 8GB/16GB]
    vendor: Razer USA driver: nvidia v: 535.98 arch: Ampere pcie: speed: 5 GT/s
    lanes: 8 ports: active: none off: DP-1 empty: DP-2,HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 10de:249c
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Razer USA driver: amdgpu v: kernel arch: GCN-5 pcie: speed: 8 GT/s
    lanes: 16 ports: active: none off: eDP-1 empty: none bus-ID: 04:00.0
    chip-ID: 1002:1638 temp: 67.0 C
  Device-3: AVerMedia Live Streamer CAM 313 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-2:3 chip-ID: 07ca:313a
  Device-4: IMC Networks Integrated Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-4:2 chip-ID: 13d3:56d5
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia dri: radeonsi gpu: amdgpu,nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3440x1440 s-dpi: 96
  Monitor-1: DP-1 mapped: DP-1-0 note: disabled pos: primary
    model: Acer CB342CK res: 3440x1440 dpi: 109 diag: 871mm (34.3")
  Monitor-2: eDP-1 note: disabled model: TL140BDXP02-0 res: 3440x1440
    dpi: 210 diag: 355mm (14")
  API: OpenGL v: 4.6 Mesa 23.1.5 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.52 6.4.10-arch1-1) direct-render: Yes
  Device-1: NVIDIA GA104 High Definition Audio vendor: Razer USA
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 8 bus-ID: 01:00.1
    chip-ID: 10de:228b
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Razer USA
    driver: snd_rn_pci_acp3x v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 04:00.5 chip-ID: 1022:15e2
  Device-3: AMD Family 17h/19h HD Audio vendor: Razer USA
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 04:00.6 chip-ID: 1022:15e3
  Device-4: AVerMedia Live Streamer CAM 313 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-2:3 chip-ID: 07ca:313a
  API: ALSA v: k6.4.10-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:2725
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-3:2 chip-ID: 8087:0032
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 41.87 GiB (4.4%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB1T0HBLR-00000
    size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 48.9 C
  ID-1: / size: 928.19 GiB used: 41.64 GiB (4.5%) fs: ext4 dev: /dev/nvme0n1p2
  ID-1: swap-1 type: partition size: 8.8 GiB used: 256 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3
  System Temperatures: cpu: 89.9 C mobo: N/A gpu: amdgpu temp: 67.0 C
  Fan Speeds (RPM): N/A
  Processes: 356 Uptime: 28m Memory: total: 16 GiB note: est.
  available: 15.03 GiB used: 4.76 GiB (31.7%) Init: systemd v: 254
  default: graphical Compilers: gcc: 13.2.1 Packages: pm: pacman pkgs: 1092
  Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.28

Here’s my powertop report on battery, backlight off, nothing running, radios off:

    The battery reports a discharge rate of 13.4 W
The energy consumed was 335 J
The estimated remaining time is 4 hours, 46 minutes

Summary: 824.5 wakeups/second,  0.0 GPU ops/seconds, 0.0 VFS ops/sec and 9.7% CPU use

Power est.              Usage       Events/s    Category       Description
  3.61 W     20.0%                      Device         Display backlight
  425 mW     45.3 ms/s      0.00        Process        [PID 347] [kworker/0:2]
  120 mW      5.7 ms/s     246.4        Interrupt      [6] AMDI0010:03
  113 mW     12.0 ms/s      0.00        Process        [PID 278] [kworker/2:3]
 96.9 mW      5.7 ms/s     162.0        Interrupt      [93] amdgpu
 58.2 mW      4.4 ms/s      62.6        Process        [PID 887] /usr/lib/Xorg -nolisten tcp -background none
 47.6 mW      3.7 ms/s      49.2        Process        [PID 1081] /usr/bin/kwin_x11 --replace
 46.3 mW      4.3 ms/s      21.1        Process        [PID 2582] /usr/bin/konsole
 35.9 mW      2.7 ms/s      39.6        Process        [PID 948] /usr/lib/Xorg -nolisten tcp -background none
 25.4 mW      0.9 ms/s      64.0        Timer          tick_sched_timer
 22.6 mW      2.2 ms/s       6.9        Process        [PID 316] [irq/30-1A582014]
 22.6 mW      1.3 ms/s      40.3        Process        [PID 1091] /usr/bin/kwin_x11 --replace
 18.3 mW      0.9 ms/s      37.9        Interrupt      [7] pinctrl_amd
 10.3 mW      1.0 ms/s       3.3        Process        [PID 4038] /usr/bin/kwrite
 9.57 mW    485.5 µs/s      18.7        Process        [PID 2584] /usr/bin/konsole
 8.25 mW      0.7 ms/s       5.2        Interrupt      [7] sched(softirq)
 6.88 mW    293.6 µs/s      15.4        Process        [PID 867] [gfx_low]

Sorry for the late reply, but it seems a few of your issues are listed on the Archwiki page for Razer Blade devices.

1 Like

Thank you! So it seems that the headphone jack is still not supported in Linux yet.

I’m trying to figure out how to "

first fully load uvcvideo module after system has completely started and then after that unload and unbind.

I tried sudo modprobe uvcvideo, then sudo rmmod -f uvcvideo, and then sudo echo -n 1-3:1.0 | tee -a unbind (I think that 1-3 is the webcam), but the power usage is still very high, so I suspect that I didn’t follow that properly.

Anything else should I be looking at?

For anyone stumbling upon this page, I fixed:

  1. The Battery issue by downgrading from nVidia 535xx to nVidia 525xxx (power management with optimus is borked in 535, the dGPU is never powered down)
  2. The headset issue by buying a cheap small USB audio adapter (Trond); the headset jack still doesn’t work.
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.