Endeavour OS installation failed

Hi, I am new to EndeavourOS, I have been trying to install endeavour OS for the past two days.
I am trying to install eos on hp omen 16 2023 model.

I tried to dual-boot with win11 but after failing a few times I gave up win and tried to install eos on the whole drive but it din’t work. I tried online, offline, updating mirrors, changing bootloaders but nothing worked.

here’s my log file:

I have only saved these 2 files cause remaining errors I got were pacman install failed and bad main file… which I already tried from the forum but it din’t get solved…


  1. You have unselected EndeavourOS tools and apps?
  2. Used ISO is not the latest, with latest Release ISO you would not have the issue.
  • === START CALAMARES 3.3.5 from the logs latest is: 3.3.7

You can leave welcome app selected and it will install without the error. (In case you can not download latest ISO)

It is also hotfixed on Gemini ISO but in case you can not reach GitHubU/GitLab it is not able to insert the fix for you.

Get the latest ISO here:


Thank you, it worked!!
I din’t download the lastest iso but selected the EndeavourOS apps but can I ask how does that fix this issue??

1 Like

Install process was using a script installed from the apps and in case you are not having it checked it is missing and generating an “error” what let installer bail out…
You can uninstall the apps on installed system without any issue.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.