Encrypted boot, root with swap fails

Hello, and thank you for this OS.

Have tried with a blank SSD, and with MBR and partition, and it fails when creating the swap, I think it is. A big pop-up pops up, with that it did, but with an error. Using “erase disk”.

Edit: From Github https://github.com/calamares/calamares/issues/1196

Based on your log you are still using 3.2.10 . Well, we updated to 3.2.11 and changed the whole setup of encryption. Please redo your tests and report back if the issue is still given. You may use 18.1-rc5 install medias from Manjaro, which provide the latest CAL already.

Is the stable using Calmares 3.2.11?

Hi!
Indeed the july’s iso uses 3.2.10. The august one will bring version 3.2.11 but the bug remains, so it’s still not possible to install swap + encryption.

The bug appears at least in arch-based distros (arcolinux, endeavour), since manjaro compile it’s own packages is possible that they no longer have the issue.

1 Like

on my 1000 testings i can see that if you crate swap manually, before install and swapon you can install encrypted, but swap will not be encrypted then :wink: Also working mostly if you do manual partition and crate the swap there… the issue is that encryption work only if you encrypt one device.
The only test i do not do is to create swap before and encrypt it outside installer beforehand…

2 Likes

Thank you! It’s easy to fix. Create the main partition and a swap partition in Gparted, choose linux-swap for it. ‘sudo swapon’ /dev/sda2’ in a terminal after quitting Gparted. Calamares will add the swap to fstab. Do ‘sudo swapoff /dev/sda2’ after first boot, and follow: https://wiki.archlinux.org/index.php/Dm-crypt/Swap_encryption#UUID_and_LABEL

i try this also but it was not working here, may i try again… would be good to have a solution for full encrypted install for notebooks.

1 Like

this is working here too now i have had a typo only… nice! but only with manual intervention :frowning:

1 Like