Enabling USB wireless device

Wireless connection has been if-fy on a Minisforum UM700 (Arch). One minute fast.com reports 100Mbps download speeds and a few minutes later we are unable to ping Various other devices, mostly Apple, on the WiFi network are working fine.

To troubleshoot I want to compare connectivity on booting from a USB drive with Endeavouros_Cassini_Nova-03-2023_R2 with a normal boot. I also want to compare connectivity using a ALFA AWUS036AXM WiFi 6E 3000 mbps Tri Band 2.4/5/6 GHz WiFi USB Adapter × 1, while booting from both the EOS USB and the UM700 SSD.

This amounts to four scenarios, which I am hoping will give me some insight into the problem, especially on whether it is software or hardware related.

The problem is, how to make sure whether it is the WiFi USB adapter or the UM700’s internal wireless card that is being used for connectivity when the USB adapter is inserted. To be honest, it’s my first experience with a WiFi USB Adapter. I chose the AWUS036AXM because it is reported to work with (newer kernel) Linux out of the box..

“ip link” seems to detect both WiFi devices:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 1c:83:41:30:ef:12 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether 44:af:28:7b:12:f9 brd ff:ff:ff:ff:ff:ff
4: wlp4s0f4u1i3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DORMANT group default qlen 1000
    link/ether f6:02:ba:de:3d:67 brd ff:ff:ff:ff:ff:ff permaddr 00:c0:ca:b5:58:cf

However, neither “inxi -N”

  Device-1: Intel Wireless 7265 driver: iwlwifi
  Device-2: Intel Ethernet I225-V driver: igc

or lspci:

 lspci -v | grep -A 10 -i "Network Controller"
02:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)
        Subsystem: Intel Corporation Dual Band Wireless-AC 7265 [Stone Peak 2 AC]

show anything about the AWUS036AXM, which I assume is wlp4s0f4u1i3. “ip link” is reporting the wlp4s0f4u1i3 as UP, but with NO-CARRIER, which I am guessing means it cannot find an SSID.

The first thing I’d like to do is enable the WiFi USB device. “sudo ip link set wlp2s0 down” certainly disconnects the UM700’s internal wireless but “sudo ip link set wlp4s0f4u1i3 up” just results in the NO-CARRIER issue.

Anyone familiar with how to proceed here?

 wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether 44:af:28:7b:12:f9 brd ff:ff:ff:ff:ff:ff

If wireless is working you should see it in the network connection by right click on it. Not sure what desktop you are using?

Thanks for replying. Using LXQt. There are two wireless devices here, wlp2s0, which came with the computer and is working but very poorly for some reason, and wlp4s0f4u1i3, which is a USB WiFi adapter. What I want to know is how to switch between them. This will help me troubleshoot. wlp2s0 seems to connect by default. What I want to know is how to connect with wlp4s0f4u1i3.

Not really sure? Never had to do this before. I have multiple network connections enabled and a WiFi but never had more than one WiFi before. I would assume you just disable the onboard one. Should be a a way to turn it off. Then get the other one turned on and should be able to connect to it. Or I would assume you could actually have both both up and running. If i right click on my network connection and select configure network connections it shows all of them.

With “ip link” I’ve effectively turned off wlp2s0. But it seemed to revert to being on after reboot. And with ip link I’ve been able to set up but it reports NO-CARRIER. As best I understand NO-CARRIER means wlp4s0f3u2i3 is not associated and authenticated with a SSID. So one possible solution is to try to associate and authenticate it, perhaps through the network manager applet in the system tray.
Unfortunately, I don’t have the computer with me and am troubleshooting from a distance when I can get the chance, but I suppose that is the next thing I’ll try.
I understand most people would not need more than one WiFi adapter. I’m using this one for troubleshooting, because if I can get a reliable and steady Internet connection with the USB device, that might tell me I’m dealing with a hardware problem with the built in Intel Wireless 7265. Also, the USB device can handle W6.

Assuming you are using network manager, you should be able to disable autoconnect in the GUI, or using some variant of nmcli conn modify, but start with man nmcli and nmcli conn help.

Also check in /etc/NetworkManager/system-connections, where you will find the connection configs. If you want to hack the files, you probably should use systemctl stop NetworkManager then hack the files, and then systemctl start NetworkManager. Hacking the files is useful if you want to copy the wifi config, ie ssid/password, because the interface name is hardwired into the config, irritating, but may be necessary in some situations. I don’t use NM much, so mainly I know that it is a PITA when I configure a bridge and want to pirate the MAC from one of the NICs, eventually I win, but lots of reading, and it is getting easier as I do it more times.

If instead of NetworkManager, you system uses systemd-networkd, then try networkctl, and I think the config is in /etc/systemd/network, but check the systemd-networkd doco.

If you don’t want to use NM, but just want to use command line like ip, then you probably need to check out iw as well, and wpa_supplicant, and probably dhcpcd, or whichever DHCP client your desktop uses.

Just out of curiosity is it possible to have both wireless interfaces enabled and active? Ricklinux stated having

Is that Ethernet connections? I wonder what happens in Windows (or Mac) when a USB wireless adapter is inserted. After the driver search of course.

I don’t see any reason why not? :man_shrugging:

Just curious Ricklinux, what is your usual DE? I’ve played with many but it’s been a long time since I’ve really used anything besides LXQt, Openbox or Sway. And there’s always something new to learn. I’ve never had this issue with connecting a USB adapter come up, never needed to, and I guess by the response here, not a lot of people have, but it’s worth knowing, in case our regular WiFi hardware fails.
I have the feeling this might be something simple. In any case, I’m looking for a simple solution as I have to communicate it to someone remotely.
I looked under “Edit Connections” in the network manager applet in LXQt system tray, and under Wi-Fi there is a section called Device. In my case wlp3s0 is selected and is the only thing to select since I don’t have a USB device, but perhaps here lies an opportunity to select the USB adapter and see what happens. (How I wish I had a USB adapter available for testing, but funds don’t allow right now). I’ll post here when I get the chance to try. Be nice to hear from someone who has done it though.

I use Kde mostly because i like how well it works without any issues usually.

Gnome/NetworkManager binds the wlan interface name into the SSID connection data, so I have to add the same authentication data multiple times for multiple wlan interfaces. Sometimes that is good, if you want to predictably connect on a device, but if you have multiple devices and maybe want to use an external device with a high gain antenna in certain circumstances, I would prefer to just be able to have SSID connections, and turn on/off devices and they work with the connect rather than having to have specific connections.

When I was checking out NM system connections, I was swapping between manjaro and eos, and they name the wireless connections differently, wlan0 vs wlp3s0, and I had to change the interface name to get the configuration to stick. The names are just names, wlanX is the default that happens when the device is instantiated by the kernel, and wlp3s0 etc happens after the device goes thru udev rules which rename for predictability, or udev remembers each wlanX by mac address, and uses predictable wlanX, or there aren’t rules for persistence/predictability and it just starts from 0 each boot, all totally changeable by udev rules.

So certainly you could have 2 wifi interfaces active. Doesn’t really matter to the kernel. I often have wifi and ethernet active, on the same network, with the same IP address, with the same mac address. I just ensure that the WiFi interface has a different IP route metric so it is picked last, so when I remove the laptop from the docking station, the ethernet drops, and that route becomes unavailable, and the WiFi picks up, and because they have the same mac address all the existing ARP entries work.

If you have two interfaces on the same network, either WiFi, ethernet, or a mix, then you need to pay attention to the details and what you want to happen. If you just have them on the same WiFi network getting a different IP addresses from the DHCP server, and having the same routing metric, then I guess they result might be somewhat random packet distribution, and outgoing connection IP address. I don’t know, and haven’t tested that combination. If you get around to testing that, then you can use tcpdump, tshark, wireshark to observe the packet flows and find out what is actually happening.

If you have both WiFi interfaces connected to different IP networks then it should just work. While it is possible that the connections can be on the same SSID, and you could assign different IP addresses and networks even using the same SSID assuming you have the WiFi AP setup correctly, although I would prefer to setup up different SSIDs.

So you need to think about what you want to happen if you have 2 WiFi interfaces active, and the questions will mostly be based around IP address, network, network routing, all standard IP questions with multiple interfaces, WiFi wise, 2 interfaces near each other means more interference, so probably less bandwidth if on the same frequency/channel.

If you want to do something like connect to something like a hotel WiFi on one interface, and share that connection on the other interface with your other WiFi gadgets, you can, but you will probably have to set NAT / IPMasquerade for outgoing packets on the hotel WiFi link. This can be done with just 1 WiFi, but I think would have to be done on the same frequency/channel, at least that is what happens on my GL-iNet mini router, and while I have plans to build a new kernel with support for extra USB WiFi adapters for that device, I haven’t done it yet, but I expect it will work, and then I could gateway on different frequencies/channels.

There are lots of possibilities, depends exactly what you want to accomplish, and you might have to think a bit deeper than I just want it to “work”, and decide what “work” really means for you, since you are talking about a non-standard situation which often has unexpected consequences, and you might also find limitations in you WiFI AP which is also not expecting that situation. The more I think of the possible configurations to more I would rather avoid.

Newer WiFi standards have support for multiple frequencies and multiple channels all in the same WiFi device, and it would be much easier to use that than try and build your own using multiple discrete devices if that is what you were thinking about too. It could probably be done, I’ve see something in OpenWRT with batman, whatever that is, support and it seems to be related, but I don’t know really know anything about it at all even if it supports multiple link devices.