Enabling kwallet and gnome keyring pam on KDE SDDM completely locks me out of my computer

I wanted to have my kwallet and gnome-keyring unlocked on boot, so I went and uncommented the keyring parameters in /etc/pam.d/sddm as per the ArchLinux wiki and now SDDM will not unlock at all. My pam looks like this when I installed it

  GNU nano 5.8                             /etc/pam.d/sddm                              Modified  

auth            include         system-login
-auth           optional        pam_gnome_keyring.so
-auth   optional  pam_kwallet5.so

account         include         system-login

password        include         system-login
-password       optional        pam_gnome_keyring.so use_authtok

session         optional        pam_keyinit.so force revoke
session         include         system-login
-session                optional        pam_gnome_keyring.so auto_start
-session  optional  pam_kwallet5.so auto_start

How do I fix this, and how do I make the keyrings unlock on boot?

Have you tried logging in on a TTY and reverting the change you made temporarily?

I tried undoing the changes, but it still won’t unlock. It just keeps saying “login failed”

OH, I got it fixed! I managed to get sudo journalctl -f to capture the process of me logging in, and noticed that I accidentally had a lingering letter in the pam file (which was the thing that kept the pam file from being loaded, hence it would throw a “unknown module” error in the logs). Removing that lingering letter fixed the issue


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.