Enable Dolphin Root access, finaly!

Today i got the KDE Framework update to 5.91.

Not only does it not make any sense (for the user) that all major DEs do not allow to use the file manager as Root (without hacks, extensions, and/or other workarounds), but it also makes it incredibly cumbersome, KDE (or the developers) finally decided to make this possible with KDE Frameworks 5.91.

After decades! (Edit: just to clarify: since i have this problem)

I was of course very pleased. Doesn’t seem to work though, or I have to set some option or something. Can’t find anything unfortunately.

Until now I have always used the file manager XFE for this, because this can be used flawlessly as root.

Do somebody know something more about this “new” Feature in KDE?

“Decades” is quite the exaggeration; using Dolphin as root was disabled in 2017, so 5 years ago. Here’s the commit (via the Wayback Machine):



Ok, thats nice for KDE :slight_smile:

But this didnt help me.

But if it helps you, for me it stopped working with Gnome 3 (~2010?). Since than im using workarounds or extensions for that. Last year i switched to KDE (just of curosity, because last time i used it was even longer). And there it never worked. So for me this Problem is still existing since decades.

Nemo comes with “Open as root” on right-click out-of-the-box.
That’s what I use on Gnome.


I thought the whole point of the update is that you didn’t have to do that anymore because there is no reason to run it as root. In theory, they added support to escalate privs when needed.

Of course, I haven’t tested it yet.

That being said, are we sure that frameworks alone is enough to make this happen? We don’t have to also wait for the next kde gear update to get the updates to dolphin?

You are certainly right. That works on my machine but I noticed it doesn’t work on my virtual machine. Strange. I must have done some other spells along the way.

I edited the post to hide it just in case.

sudo mc

It’s never been a problem for me.


Update: According to KDE developer Nate Graham, the root file operations feature has been reverted as it needs to be “re-done with an eye towards more technical correctness.” For now, this feature appears to only be available in the KDE neon Unstable distribution!


Newly added (ie reintroduced) for dolphin maybe, but its been in KDE the whole time in krusader.

Superior file manager to dolphin anyway.

If you are editing any file with root permissions you should really be using sudoedit anyway, not a file manager.


Ah crap.

So again years of waiting :face_with_diagonal_mouth:

And this, is a workaround :slight_smile: This wasnt the plan/way of KDE. Sure it exist dozen of ways how to force to open Dolphin as Root.

Yeah, you right. Sure you can work from CLI. But to be able to drag n’ drop, with nice big icons, its a nice thing.

Your right. And i use XFE for it (because less depencies). But the standard Filemanager from KDE/Gnome arent able to do that natively.

On KDE you didnt need this anyway, because Kate ask you for the root password if needed.

But you cant create folders with dolphin in root folders. Or copy them (copy to root folders). Or anything else what you can do with files until you force open Dolphin with any workaround.

Stop using dolphin and use krusader then.

Problem solved.

sudoedit is much safer.


The point of sudoedit is to allow users to edit files they wouldn’t otherwise be allowed to, while running an unprivileged editor. To make this happen, sudoedit copies the file to be edited to a temporary location, makes it writable by the requesting user, and opens it in the configured editor. That’s why the editor shows an unrelated filename in a temporary directory. When the editor exits, sudoedit checks whether any changes were really made, and copies the changed temporary file back to its original location if necessary.



That’s why I like mc, you can copy and paste delete and everything other than actually drag and drop. It’s very rare I need to do anything file manager wise with root, but the couple times per year, it’s easy enough for me.

If I’m not mistaken, openSUSE has had this feature for a while now in their dolphin manager.

Ok. Why? KDE do this the sameway (polkit possible), only that i dont have to open a Terminal first, and then to type EDITOR_SUDO=kate $somefile.

Sure. Thats fine if you dont need to do it often.

Nah, thats not enough to choose the opensuse way :laughing: i really like endeavouros.

But ok, since @EOS posted a Link to a newssite about this problem that it was reverted again, this thread can be closed. Otherwise this thread starts to be again a flamewars thread one more time :laughing:

@Bryanpwo can you close this thread? thank you very much.

Have all a nice day.

No need to ping someone directly. Bryan is away at the moment you can just use @moderators.