Empty pacman file lists prevent upgrade

I have a problem with an installation of EndeavourOS dating from a few months back. It failed to boot with a problem of not finding vm-linuz in the /boot directory for some unknown reason.

Unfortunately I was absent for a while and did not have time to try and fix the problem until recently and was relatively successful in following instructions to use a live arch iso and reinstalling the linux kernel using archlinux-chroot. It now boots into a notrmal xfce4 dekstop but I have a problem of dependency conflicts when I try to upgrade the system with pacman.

For another mysterious reason (to me at least) the three files that normally should be in
have disappeared and pacman then replaces wxgtk-common and wxgtk3 with packages from the extra repository - again for reasons I cannot fathom. But it further warns me of conflicting packages:
wireplumber and pipewire-media-session have conflicting depencies.
If I try to remove pipewire-media-session to settle the dispute, pacman further complains of more broken dependencies and prevents me continuing.
As for wireplumber, it can’t be located because of the missing files in pacamn-6.0.1-5/ directory.

On my upgraded laptop I can see the missing files, but the folder has a more recent number “6.0.1-7” quite logically I suppose because of the upgrade.
I had thought of simply copying across the missing files, but hesitate to do so as the list of files will probably not correspond and even worse problems may arise.

Would it be possible to do a downgrade of my system in the hope of recovering the missing files? I have read that cleaning the cache would not help as it doesn’t touch the database list.

Can we see the full output from sudo pacman -Syu so we can see what is happening?

This stuff all looks normal to me and shouldn’t be related to missing files.

:: Starting full system upgrade
error: could not open file /var/lib/pacman/local/pacman-6.0.1-5/desc
:: Replace wxgtk-common with extra/wxwidgets-common? [Y/n]
:: Replace wxgtk3 with extra/wxwidgets-gtk3? [Y/n]
resolving dependencies...
looking for conflicting packages...
warning: could not fully load metadata for package pacman-6.0.1-5
error: failed to prepare transaction (invalid or corrupted package)

The upgrade stops there. Thanks for quick reply.

You can fix that by following the instructions here:

If you are still getting errors after that, post the new output here.

Performed the deception by creating the 3 empty files that were needed but when I tried to reinstall pacman it complained that it was already installed and gave a long list of all the files that already existed. and refused to upgrade.

However, I tried pacman -Syu and now it is going through a complete upgrade.
Alas! After downloading over 400 packages it said a number of packages in the cache had invalid sigantures and the upgrade procedure ended with …

Errors occurred, no packages were upgraded

We really need to see the full output for these things but in this case you need to do this before upgrading:

sudo pacman -Sy archlinux-keyring
sudo pacman -Syu

I did the upgrade of the keyring first thing while I was in the arch chroot. So there’s no problem there.

The upgrade didn’t work as I suspect there may be traces of the the old pacman version 1-15 when we’re now at 1-17. Is it possible to downgrade to an older pacman version?

Please share the full output from pacman -Syu. Otherwise, we are just guessing.

It looks to me like your pacman is working so I am not sure that you need to downgrade pacman unless something in your output shows otherwise.

Thanks for the help, but as I have to leave on a short break I decided to reinstall to end my problems as it was frustrating to see pacman apparently downloading upgrades but then refusing to install them. I’ll use timeshift in future to get snapshots to switch back if I have problems of the sort in future. Thanks anyway.

you can also use btrfs-assistant and snapper-support, that way you can boot into a snapshot from grub then use the aforementioned assistant to REALLY restore.

disclaimer: just like raid, btrfs snapshots aren’t a real backup. if the actual drive fails ur screwed.