Emoji not showing in terminal

Hi, I just installed starship prompt, which is cool, but it does not show the emoji, but only a box, like this:
Screenshot_20220829_114106

I have installed the noto-fonts-emoji but it still not working… how can I fix this?

the font section in KDE settings shows this:
Screenshot_20220829_114211

did you restart your system afterwards?

Edit:
after a restart the font should be available.

1 Like

in my opinion you need some nerd fonts like

Fira-Code

or

Iosevka

take a look at nerdfonts

I have installed fira-code for my oh-my-zsh and worked fine.

settings

1 Like

reboot does not work, however, I manages to get it works by creating this file:

~ 
❯ cat .config/fontconfig/fonts.conf 
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "urn:fontconfig:fonts.dtd">
<fontconfig>
 <alias>
   <family>sans-serif</family>
   <prefer>
     <family>Noto Sans</family>
     <family>Noto Color Emoji</family>
     <family>DejaVu Sans</family>
   </prefer> 
 </alias>

 <alias>
   <family>serif</family>
   <prefer>
     <family>Noto Serif</family>
     <family>Noto Color Emoji</family>
     <family>DejaVu Serif</family>
   </prefer>
 </alias>

 <alias>
  <family>monospace</family>
  <prefer>
    <family>Noto Sans Mono</family>
    <family>Noto Color Emoji</family>
   </prefer>
 </alias>
</fontconfig>
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.