Emergency Mode - System Can't Boot

I had somehow added a partition to my system that was labeled CentOS. It just was empty and I went ahead and deleted it and then resized my system and now I boot into emergency mode. I have no access to another system and basically everything I look up everyone says today boot live USB. I don’t have that option.


I dunno if this will help also
Ctrl d just brings back to starting default.target then nothing

What do you mean? Do you mean you don’t have the USB/CD that you used to install EndeavourOS?

Correct and I lack any other access currently to create one.

You’re going to need one. You should always have a USB/CD with a live ISO, even if it’s not the same distro.

I’m not sure what can be done without one, so you’ll have to wait for some of our more experienced members to chip in.

Thanks again. I even tried to go to the library today but as you can imagine burning the iso wasn’t exactly allowed

Yeah, that makes sense.

Looking at the picture, it looks like your system has got to the OS, but just won’t load. That much is a “positive” thing. At least it recognises it.

PS: In the future, and after this is resolved somehow, always have a live ISO on a USB/CD that isn’t used for anything but that. Every time there is a new ISO for your OS of choice, download it, test it, and if it works properly (meaning you can boot into it), then you can replace the old ISO.

Treat it like part of your system maintenance routine.

1 Like


I dunno if this makes any sense to you or not but basically everything I have been reading and trying is giving my positive readouts

Except. This

Also, welcome to the community! I hope everything works out. :vulcan_salute: :enos_flag:

Hmm. When was the last time you updated your BIOS?

I just got the machine a month ago

That doesn’t really affect whether you need a BIOS update.

Try this (it may not work):

nano /etc/pacman.conf

Based on the errors you’ve shown (in the second set of images), there seems to be a problem with your OS being able to communicate with your hardware. The first set seems like a failed attempt from pacman to reach the necessary repos.

Anyway, for the most part, you’ll just have to wait for someone with more experience and knowledge in this area.

it’s the first picture that’s alarming. all the can’t mount/fstab fubar’d stuff. that suggests a boot problem and the second one I’ve seen today.

the second pic not good because @ddnn is right, you need to do this stuff because mirror craziness.
fix the mirrors, get proper updates, the boot mount fixes itself? sometimes.

reflector --protocol https --verbose --latest 25 --sort rate --save /etc/pacman.d/mirrorlist
yay -Syyu
eos-rankmirrors --verbose
yay -Syyu

if you can’t get a terminal while booting (ctrl+F-key-something-try-them-all-til you get terminal) then nothing I say here matters. I see a terminal in the first pic I think.

Do you have access to an Android phone and internet connection?

If positive, download the iso into your phone.

Install EtchDroid.

Connect a usb flashdrive to your phone.

Launch EtchDroid and follow the instructions.

PS. make sure your phone’s battery is fully charged as the process may take some time.

2 Likes

Ok thanks everyone. Iam going to try all this. I am able to login as root through emergency mode but other then that no other terminal but I will try what you. Said.
And I am downloading the android software as we speak thanks again

So I have a the ability to not only access terminal but running
Startxfce4 opens Xfce4 desktop nly network manager isn’t running. How can I get a conneçifon

BIG thanks yo everyone who helped me. But I’ve actually solved it just by removing a line from the /etc/fstab naming a deleted partition.

Thanks again

1 Like