Electron25 fails; No module named 'six.moves'


I am trying to update my system & electron25 is failing with six.moves. I do see I had python3.12 installed, is ran yay -dd -R python to remove before the upgrade. Same error came.

I also update Arch mirrors and EndeavourOS mirrors to see if issues would resolve without success.

Guidance is appreciated,


Since python-six is a build dependency, I would try installing/rebuilding it first.

In most cases, you can uninstall electron25. It is an older version of electron and updated software really shouldn’t be using it anymore.

Also, using -Rdd on python is a really bad idea. There are many things relying on python to operate.

I tried installing python-six without any changes.

Final fix. This sped up updates significantly without having to clone electron25 each time. Someone posted on reddit recently with this fix for slow updates on electron25 repo.

yay -R electron25 electron25-debug
yay -S electron25-bin electron25-bin-debug

Thank you all for whom gave advice & replies!