Editing fstab mounts into default desktop

I made a mistake in editing /etc/fstab/ to automount a disk. I marked /home for two of them, run mount -a and rebooted. It now boots into default desktop without access to my desktop and disks. How can I get it running back? Tia :grinning:

Have you tried editing /etc/fstab, fixing the problem and rebooting?

If you need to you can access a TTY using ctrl+alt+f3

Yes. I tried it before posting and the fstab file is blank (also in tty). Should I remake the file?

If all you did was edit /etc/fstab then you must have mounted over your /etc/ somehow.

I would boot off the live ISO, mount the root partition and see if /etc/fstab is visible there.

I would boot off the live ISO, mount the root partition and see if /etc/fstab is visible there.

Yup its there. What do you think I should do next

Can you paste the contents of it here?

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=CF52-1460 /boot/efi vfat umask=0077 0 2
UUID=b441e1ae-0c00-4108-96bb-10e872f2b71c / ext4 defaults,noatime 0 1
UUID=3bc7d494-a1e4-4788-962a-7b7cec3d1e50 swap swap defaults,noatime 0 0
UUID=00caca7b-3ac4-44c1-a8bc-856c003aad16 /home ext4 nofail,user,noatime 0 1

Have you fixed it already? I don’t see any duplication there.

You probably shouldn’t be mounting /home with user or nofail.

I think I remembered it wrong about flagging duplicate. Was multitasking on a call.

I just found out that removing /home on second drive solved the problem

Change number 1 to 2 (end of line).

<fsck> sets the order for file system checks at boot time; see fsck(8). For the root device it should be 1. For other partitions it should be 2, or 0 to disable checking.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.