Edge App missing controls

Hey guys, silly post about the option to install the site as an app (specially since the forum has the prompt to do so, unlike doing it only manually).
I’ve asked other pages/forums to get this and as far as I know it’s something the admins have to activate it seems. For example, here’s LTT forums. And here’s EOS forums. That’s all, thank you! And yes, I know you can alt-left arrow or right click > back but it isn’t the same :pensive:

I haven’t the foggiest idea what you’re talking about. What do you want the forum admins to do? What is this Edge App? Is this some 𝖕𝖗𝖔𝖕𝖗𝖎𝖊𝖙𝖆𝖗𝖞 filth from Micro$oft?

2 Likes

I guess he wants admins to turn on the setting in Discourse that it allows the browser to create UWP app of the web page (if your browser supports it).

What’s UWP? Is this some 𝖕𝖗𝖔𝖕𝖗𝖎𝖊𝖙𝖆𝖗𝖞 spyware tool from Micro$oft?

I duck-duck-goed it, and it just speaks of telemetry and “insights”… And it’s all about windoze. What in the deuce does that have to do with a GNU/Linux distribution such as EndeavourOS?

ACtually its not an UWP app, got my words mixed. Its just a basic web technology to create an “app” from a web page that supports it.

Its nothing to do with proprietary or Microsoft

Most browser does I think.

This my Vivaldi.

After installing.

2 Likes

I don’t see this on Firefox?

Chrome:

app

2 Likes

I don’t think Firefox supports it

As far as I knew, it’s a PWA feature for Edge, but perhaps it’s a feature that all Chromium-based browsers got.
edit: seeing the responses, it seems to be a Chromium feature.
You can technically install any site as an app manually, but there are some (I assume made available as such) that prompt you to do so. Most notable ones Reddit, YouTube. Endeavour OS forums was another one.
What happens is that sometimes, some have on the title bar the button controls for “refresh” and “go back” - as seen on the screenshots. As far as I know, it’s something that needs to be activated by the devs. At least that’s what happened on the LTT forums page. After a short while an admin let me know to delete cache and reinstall to see the changes made.

This topic on Discourse forum might give some light: https://meta.discourse.org/t/add-to-homescreen-banner-on-android/42973

@latisullivan
I think this refresh and go feature is a plugin, it isn’t something that isn’t shipped by default. I will look for it if it exists and if it is an officially supported plugin, I will implement it. Just give me some time, at the moment I’m busy with a lot of other stuff.

@ricklinux
Firefox does have that option also, go to the website on your mobile device, hit the menu, then hit add to start screen or home screen, I don’t know how it is called in English.

2 Likes

Please Bryan, take all the time you need. It is not a priority at all, I understand that :grinning_face_with_smiling_eyes: . Thanks a lot!

I will in the meantime do some more research on my own and ask around, maybe I can get some info to make it easier for you.

1 Like

@Bryanpwo
Here’s what the admin of the other site responded: The problem was that the PWA was previously configured to use the standalone display mode, but that is a bit too minimal so I switched it to minimal-ui instead.

And he appointed me to this site.
I believe this would be the answer, as I saw it somewhere else too. But just in case it isn’t, there’s also this reddit comment about it, althought it’s from a year ago and I believe it’s not related to the configuration.

Again, not a priority so no problem for now (I also enabled the flag of return with backspace, so I can work with that in the meantime). Thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.