Easily restart KDE!

Hello guys, I’ve been using Linux for quite awhile with KDE as my DE of choice. Every so often, KDE decides to be annoying and quit working properly. When this happened on GNOME, I know I could use ALT+F2, then R. KDE had no such option and that only worked on x11 anyway. To solve this, I made a .desktop file to restart it quickly without launching the terminal.

Here it is!


[Desktop Entry]
Comment[en_US]=Action Shortcut (DO NOT USE UNLESS YOU INTEND TO RESTART PLASMA)
Comment=Action Shortcut (DO NOT USE UNLESS YOU INTEND TO RESTART PLASMA)
Exec=killall plasmashell&&kstart5 plasmashell
GenericName[en_US]=This can fix issues like messed up time, glitchy windows, unresponsive desktops, weird icons and more!
GenericName=This can fix issues like messed up time, glitchy windows, unresponsive desktops, weird icons and more!
Icon=kde
Name=Restart Plasma Desktop!
Path=/usr/bin/
StartupNotify=true
Terminal=false
Type=Application

To use this, open a new file in Kate, paste the above text, then save it to your desktop as AnyFileNameYouWant.desktop

I just use alt+space to popup krunner, it hasn’t failed me later.
And just restart plasmashell. Obviously it happens often enough I can remember the steps (lol).

2 Likes

Haha. The main problems I have is the weather widget failing to do anything useful or the clock freezing. These problems usually take a week or longer of uptime to show themselves thankfully. I also have Krunner in my menu bar these days so I don’t even need the shortcut.

do kwin_x11 --replace also not work , just a question :slight_smile: wayland is kwin_wayland but idk… if kde hangt i would first look in the services and disable some services like baloo , or other indexer services… and which opengl you use can be a point…

1 Like


Tick that, apply, there’s your shortcut.

Also, this shouldn’t be prefixed with [Solution] like this, there’s a Solved button for a reason - and a wiki for an even better reason.

2 Likes

Relevant for KDE:

Relevant for Linux in general:

1 Like

Ok! Edited the title.

I already knew about and enabled REISUB but didn’t know about the qdbus stuff. Thanks!