DX11 games won't open.

Greetings, first of all hello. I am new to EndeavorOS and I need help. I can’t open any DX11 games. I’ve looked in most threads about this and I can’t figure it out. My previous OS was Garuda Gaming Edition. Therefore it feels a bit strange.

Hi @Flester and welcome to the forum. It would be more helpful if you list the games you are having trouble with and how you are trying to run them.

1 Like

CS2, Witcher 3, RE 2, RE 3, I have problems with all of these games. For example. In Witcher 3, when dx11 is on, it freezes the moment the image appears on the screen and does not open. Or it’s like opening in CS2. It goes on the yellow screen of the game just as it will open. + When I turn on dx12 in Witcher 3, the game runs comfortably for 10-20 minutes. Then it freezes and closes. Just like in DX11.

Are you running these through steam? If so a helpful site to use would be protondb and seeing what others have done to overcome similar issues.


Yes, I’m running it through Steam, and I’ve tried them all. CS 2 opened once. I started to play and the game froze on its own. And then it broke.

Yer I would look through protondb for a solution. I have none of these games so I cannot tell you what is needed for your system or what workarounds may be needed.

CS2 should work without any issues. Just install and play. No extra stuff required. How did you install Steam and did you force the game to start up with Proton or not?

Do you have vulkan-radeon or amdvlk installed, the 32 bit packages that is?

start with the basics.

Run glxgears and vkcube to confirm opengl and vulkan are working for you, if they’re not then that’s your problem. DXVK uses vulkan.

I had this issue when I was compiling proton and proton-ge for native on ALHP, bur you probably don’t do that.

I would advise you to try some different proton like https://aur.archlinux.org/packages/proton-ge-custom-bin
You need https://archlinux.org/packages/multilib/x86_64/steam-native-runtime/ to do this. If it still fails, post you should post the output from steam from the terminal.

You are using XFCE. That is a bad desktop environment for games and graphics intensive applications.

I recommend you switch to Plasma (also known as KDE) or Gnome.

Horrible take. The desktop environment has likely nothing to do with his inability to run a program.

EDIT: I’m not saying it isn’t possible, but recommending doing that isn’t the first thing one should do to try and troubleshoot an issue.

If you want to use graphics intensive applications (such as games) then you don’t want XFCE as your DE !!

Edit: Don’t mean to be rude, but honestly the DE matters when it comes to performance. XFCE may seem fast and zippy, but once you give it an intensive graphics calculations it will take a performance hit - if the application will even run at all!

In my time using XFCE, the compositor was the reason the fast and zippy DE went for scrap when a game showed up. The compositor can be turned off in the settings.

Also, I feel like this isn’t relevant here. The games don’t even launch or play properly. Switching to KDE most likely won’t resolve the issue. That’s my hunch, though.

XFCE is just not for gaming and graphics intensive applications. The DE does matter performance-wise and XFCE can’t handle graphics properly.

I’m not going to argue with you on this now. Maybe after the OP gets his solution, we can have a chat here. Until then, let’s just shut up and let others come up with other ideas to help OP.

Can you share the output of the following commands?

pacman -Qqm radeon
pacman -Qqm vlk

What DE were using when you ran Garuda?

If someone wants to game on linux then XFCE is just a bad choice. People need to know that. You started this by undermining my original comment with your Horrible take comment. I stand by my advice that XFCE is not good for gaming.

Show me hard numbers that XFCE does truly suck and I will trust you.

Not sure if this is the right command. Maybe you meant:

pacman -Q | grep -i radeon
pacman -Q | grep -i vlk
pacman -Q | grep -i vul