Duplicate tray items on startup, there are two instances running of each

Screenshot-2022-11-23_16:51:51

when i click on the firewalls, each tray opens a different running instance.

but when i change the settings of one instance, the changes effect on both running instances.

the sound app, i can quit one and the other one keeps running.

so the truth is that firewall and sound both startup running two separate instances.

this has been happening since i first installed EndeavourOS on my laptop and I have not been able to resolve the issues.

thank you for any leads!

Right click on one of the items in the tray or on the clock and select “Panel >”, “Panel Preferences…

You should see a windows similar to this one:

image

Check that the “PulseAudio Plugin” is not listed twice.
I do not know about the firewall indicator but maybe it is similar?


If there are no duplicates maybe check the “Settings Manager”, “Session and Startup” in the System category.

In the window you should then select the “Application Autostart” tab. It looks like this:

image

If you see duplicate entries, try to uncheck one of them. Log out and log in again to test the changes in this dialog.

1 Like

I’m running Openbox and I’ve spent hours trying to find the culprit without success. I just live with it and move on.
tint2_tray

1 Like

there is no such option… same as @CMarch

For folks on Openbox (although this thread is about XFCE-DE) a solution has been found in this thread on Arch Linux BBS:
https://bbs.archlinux.org/viewtopic.php?id=123642

Another one here:
https://bbs.archlinux.org/viewtopic.php?id=42888

2 Likes

@ivanhoe unfortunately neither of these worked for me. I even went down the rat hole of renaming “.desktop” files in /etc/xdg/autostart so they would not start and that did not give wanted results either.

1 Like

How can we report this bug?

Did you save your session before shutting down your computer ?
It happened to me before, I had the same elements loaded twice, ones with the saved session, seconds with the autostart. I had to delete the files in ~/.cache/sessions and uncheck the save option in the shutdown dialog.

I don’t intentionally save the session before shutdown, don’t have a~/cache/sessions folder and cannot find a saved session. Unlike XFCE I don’t think Openbox can (or does) save a session. I’ve looked and looked.

I would try making a new panel and adding each item back until it either duplicates again or works as expected.

@ajgringo619 did not work. I even uninstalled tint2, rebooted, reinstalled tint2 and duplicates still exist.

it is the tray the icons appear automatically…
So no settings are there i think…
Could be you are using … dex?
yay -Qs dex

https://archlinux.org/packages/community/any/dex/

may because you have installed i3 also or tried it e.t.c.

just for reference, i have the doubled icons issue too on manjaro. it started recently (1 month max). so it’s really a thing. Not all icons are doubled (I assume not all allow two instances?).

While you’re running tint2, I think the OP is using the stock xfce4 panels.

@joekamprad I just commented dex out of the Openbox autostart script and no more double icons.

2 Likes

Could be just duplicates in the Status Tray Plugin of the panel, due to your experiments?

1 Like

and we should stay on topic… it is about xfce4 tray not tint2 … it will confuse others joining the thread with the same issue as the initial poster.

2 Likes

Maybe it’s worth a look.
https://forum.xfce.org/viewtopic.php?pid=66950

None of these suggestions have worked.

there is no option to make a new panel and this has happened since a fresh install.

it was always like this and I have not experimented with anything else. it is just Openbox Xfce4

how can this bug be reported so that the installation of the fresh installation of the OS doesnt give this type of output?

thanks

@vacicebon @joekamprad @manuel @zoli62

What happens when you right-click on the existing panel? You should get a menu like this: Panel → Panel Preferences. From there, click the plus sign near the top-right corner; hovering tool-tip should say Add a new panel.