Duplicate audio devices appearing when clicking sound icon in system tray

I have one usb notebook speaker , and on the other a line out to my amplifier. Funny, yet it shows me the devices twice.

Edit:

:man_shrugging:

I booted again with ltskernel.

Screenshot and Problems posted above are with zen. :man_shrugging:

So it’s only with zen?

1 Like

It seems so. Running fine with lts so far.

EDIT: There is a fresh kernel-update running. I will reboot again and let you know

I just also tried my HP laptop and no issue. I only use the current latest kernels.

1 Like

I have booted into zen-kernel looks fine so far.

uname -r                         
6.4.9-zen1-1-zen
                                                                                                                                          

It seems the issue comes with the kernel!

I just installed zen kernel and i have no issue. When i plug headphones in it changes from line out to headphones. :man_shrugging:

Edit: Were you on a previous zen kernel version?

I don’t have headphones. Just USB Speaker and my line out to the Amplifier

I only used the headphones to try plugging something else in and out.

@Kundalini try to update your kernel. It solved the issue on my PC !

Well, it looks like a kernel update will fix the issue.

I am back on lts. Looks good here.

 ~ uname -a
Linux ryzen 6.1.44-1-lts #1 SMP PREEMPT_DYNAMIC Tue, 08 Aug 2023 19:07:19 +0000 x86_64 GNU/Linux

Cross posting just for reference:

Just updated kernel

uname -r                                                                                                                                                                                                                               
6.4.9-arch1-1

For me the issue with apple persists even with latest kernel on pipewire 0.3.77

In any case, for me downgrading to 0.3.76 is a perfectly acceptable temporary solution that solves all my problems. But I’m glad the kernel upgrade solves the issue for others :slight_smile:

1 Like

Maybe in your case the issue is fixed with a pipewire update.
Good luck !

1 Like

After updating, still happening on both mainline and LTS kernel. I suppose I have to wait for pipewire update.

pipewire 1:0.3.77-2 has been released which includes the patch from upstream.

2 Likes