Dumped core by clicking the "x" icon in the search bar

Good afternoon. I have the following problem for which I have not found a solution.
EndeavourOS, gnome. When I click on the delete button in the search bar, which is in the overview, my session restarts. A clean reinstall of the system didn’t help (although that’s not why I reinstalled it).
On a virtual machine, the result is identical. Actually a clean installation, but with gnome selected as the desktop and the whole disk encrypted. Same as on the host. The installer image from March is EndeavourOS_Cassini_Nova-03-2023.iso.
I disable extensions, changed the search place, even disabled indexing in settings - does not help. It doesn’t matter if it’s X11 or Wayland, the result is the same.
Here are the log lines from search initialization all the way to session login - https://rentry.co/b85i4
Same thing, but for a virtual machine.
The wayland session - https://rentry.co/23w24
X11 session - https://rentry.co/3o6qz
Video from a virtual machine (I can’t physically record it on the host) -

1 Like

I can’t reproduce this on my end: Archlinux plus GNOME (Wayland)
I couldn’t think of that it might be an EnOS’ issue.

If none other forum member has stumbled upon this issue, my suggestion would be to report this upstream.

Have a look here for how to print a backtrace in case you would want to file a bug report:


Looks like I spoke to soon. Strange thing. First time I tried to reproduce the issue, it didn’t happen. Now I have tried 4-5 times after that. It happens as you described each and every time.
Seems you have discovered a :bug:

1 Like

KDE Plasma doesn’t have this bug, just sayin’… :rofl:

Welcome to the forum, David!


sad !!

1 Like


I have tried to reproduce the issue on another system: openSUSE Tumbleweed + GNOME44 Wayland.
I tried 10 consecutive times and there was no issue with clearing the search field.

I haven’t looked further at GNOME’s bug reports to see if the issue has been reported and known and now is fixed.

I can not reproduce this. Not on EndeavourOS and not on Fedora.

1 Like

Jup works the way you described it. I think there is a package or something missing in the recent eos installs

The output of the “coredumpctl info PID” command is https://rentry.co/4qyur
On the fedora 38 in the virtual machine that comes with the gnome 44, too, no such problems. But having downloaded and installed another arch based distribution of manjaro, with a similar clean installation (encryption does not affect anything, checked today) there is already this bug. In all likelihood it is either the arch linux or the calamares installer.
Given what the archwiki says about paying more attention to the “Signal” row, it seems we need to dig in the direction of “Signal: 11 (SEGV)”

1 Like