Dual Monitors both identifying to same screen

Hi everyone. I have done a fresh install with Plasma. It has detected my two monitors and happily set up in extended screen mode. However, in Display Configuration, when I click to identify each screen, they both identify to the left monitor. This is a problem when running (for instance) X-Plane where the application thinks I only have one screen and seems to overlay the output of both to that screen. Details posted below. Is there a configuration somewhere which determines which display is assigned to which screen? Any guidance gratefully received :slightly_smiling_face:

inxi -G
Graphics:
Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] driver: amdgpu
v: kernel
Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: amdgpu
unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu resolution:
1: 1920x1200~60Hz 2: 1920x1200~60Hz
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon RX 6600 XT (navi23
LLVM 14.0.6 DRM 3.48 6.0.10-arch2-1)

xrandr --listmonitors
Monitors: 2
0: +*DisplayPort-1 1920/518x1200/324+0+0 DisplayPort-1
1: +DisplayPort-2 1920/518x1200/324+1920+0 DisplayPort-2

I don’t use KDE Plasma, but have you tried configuring your displays using arandr? You might need to install it first if you don’t have it installed. sudo pacman -Syu arandr

arandr’s interface should look something like this:

Edit
If arandr works, you can save the configuration as a .sh file and then add the path of that script to your sddm.conf file under SessionCommand to run the script every time you log in. Refer to this link for more details.

Thanks for the suggestion. I gave arandr a go, and it lets me swap the screens around OK, but this didn’t solve the problem. I guess that, prior to the display manager sending each screen to the appropriate physical port, there is a layer where outputs are addressed to these screens, and this is where things are going wrong.

Try xrandr --output DP1 --mode 1920x1200 --rate 60.00 --primary and xrandr --output DP2 --mode 1920x1200 --rate 60.00 --right-of DP1 to set DP1 primary and DP2 at the right of DP1 (or use --left-of to set DP2 on the left).

This description does not help us understand the real issue, whether it is a bug or a PEBCAC.

Also, give more technical info. Subjective descriptions or opinions do not really help :person_shrugging:

xrandr --current
inxi -Gax

Find the newest file in $HOME/.local/share/kscreen/ and post its contents here.
Please, use proper code formatting in the post. Use this toolbar button </>


arandr is a great tool, but if kde display settings module has a bug, we should try to find it and report it upstream IMHO.

Thanks. I think I am making some progress (steep learning curve!). xrandr is handling the displays OK, but the windows manager (tried those in both Plasma and XFCE) is sending newly opened full screen windows destined for display 2 to display 1. Through the graphical window manager I was able to find the hidden window, switch off full-screen, drag it to the correct display, then switch on full-screen again. I have found a package called wmctrl which lets me manipulate windows after they are opened by the application, so I am writing a launcher script that will open the application and send the two full-screen windows it presents to the correct displays. This is a workaround, but it seems that the windows manager doesn’t understand multiple screen instructions from some applications.

What happens when you swap the primary display? Because it seems like the windows always got sent to your primary display (Display 1).

I mean, if you set your primary display as Display 2 and it always opens in the primary display, this automatically solves your problem, doesn’t it? Because your primary display is now Display 2, the full-screen application will now launch in Display 2, which is what you want? This is the quickest “hack” to get the behavior you intended, in my opinion.

I respectfully disagree.
Progress is to learn how to listen and follow advice, no offense…

Again… :

You keep describing what youthink is happening, not what is happening in front of your eyes. This behavior has a name, xyproblem and cannot help us help you.

If the issue happens only with Game-type programs and not with other normal applications, then you should look into that specific program vendor/forum support. Do your tests using normal applications.

BTW, what do you mean with this?:

I might be mistaken here, but I think the OP meant that clicking an icon to launch a full-screen application (maybe a game or sth; i googled X-plane and found that it was a flight simulator) will launch the window in Display 1 even though the icon was clicked inside Display 2. And he dealt with the problem by switching off full-screen and then dragging the window to the correct screen before switching to full screen again.

@goemonier You should clarify how the application was launched and also describe the window behavior in your settings. Is it “Active Screen follows mouse?” or something else? If you click an icon in Display 2 to launch the application and have the “Window Placement: under mouse” setting set, and it still opened in Display 1, then it’s definitely a bug we’re looking at. Either way, I agree with @petsam that a more detailed description of the problem is needed for us to completely understand the issue.

1 Like

Thanks @anthony93 . You are correct, the application I am testing with is indeed a flight simulator, designed to output to multiple monitors, whose displays are offset to provide a contiguous field of view. It is a single application outputting to (in my case) two full screen windows. Whichever screen I launch the application from, it opens a start-up screen in the same window as the launcher, then once loaded layers both screens on the left monitor. I have tried this with either, and with neither monitor set to primary, with the same result. Once the application is running, using wmctrl, I am able to grab one of the full-screen windows it has created, un-fullscreen it, set it’s co-ordinates to the right monitor, then re-fullscreen it. I can therefore run the application through a bash script which includes this workaround. Thanks everyone for your suggestions and patience - beyond the needs of a musician, I am not technically adept.