Dual Monitor support for Plasma6, Wayland and hybrid GPU (Intel+nVidia) setup

Hi there, I switched to Plasma 6 and Wayland last night and sorting myself out piece by piece. Now, one bigger piece I was expecting to hit me is nVidia multi monitor support which not surprisingly broke with the upgrade.
I have read up a bit on this subject but given that things were in flux for a quite a while I am not clear what the status quo is today and what might be old information.

I think I can savely expect that dual monitors should work in principle with my setup?

  • Device-1: Intel HD Graphics 530
  • Device-2: NVIDIA GM107GLM [Quadro M1000M]
  • Wayland
  • KDE6

It’s been years since I set this up for X11, so I don’t remember all the fine details but to make the second screen work I had to install bumblebeed.service, set it up with XRANDR and wire things up with intel-virtual-output.
Is this still how things are supposed to work with Wayland? Even though the nVidia components have X11 all over the place?

Current situation is that…

  1. XRANDR shows only one display, no virtual ones
Screen 0: minimum 16 x 16, current 2560 x 1440, maximum 32767 x 32767
DP-1 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 700mm x 390mm
  1. Bumblebeed.service seems to be running fine
    There are a few DRM and logo related warnings though.

  2. intel-virtual-output can’t find any virtual displays. Which is to be expected given that Xrandr doesn’t show any

No VIRTUAL outputs on ":1".
  1. The nVidia card seems to work

Testing with optirun glxspheres64 works as expected, on the primary screen only obviously.

optirun glxspheres64
Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
GLX FB config ID of window: 0xdd (8/8/8/0)
Visual ID of window: 0x40

Got 3 monitors connected to my Nvidia card and everything seems to be running fine, relatively speaking. From what you’re writing, the issue seems more connected to having a hybrid GPU setup rather than Plasma6 & Wayland being the issue itself.

I assume you have a laptop and can’t directly connect to the GPU?

Correct. It’s a Dell Latitude Laptop with a hybrid GPU setup

Have you tried to run a dual monitor setup with the integrated graphics card or GPU only? I would try that first before tinkering with the hybrid setup. At least for those two I can confirm that a dual monitor setup works for me.

Not really sure how the hybrid setup works with bumblebee, but I’d suggest to maybe update the title since this seems to be the core issue and that way people with more expertise may be able to see it.

<Have you tried to run a dual monitor setup with the integrated graphics card or GPU only?>
If I remember correctly that wasn’t possible, at least not with X11. Trying to remember all the things I had to go through back then, all I remember is that it was quite painful :slight_smile:

So I was hopping that with Wayland some of that isn’t required any longer, maybe I don’t need Bumblebee any longer?
But you are right, let me highlight the hybrid GPU in the title…

Wait, so just that we’re on the same page: You do have two physical monitor outputs on your laptop right? I’m just a bit confused because on my Dell XPS the dual monitor setup has been plug and play, especially on the onboard Intel Graphics.

I recall reading somewhere that Bumblebee wasn’t the optimal solution for Wayland, not sure where I read that and how credible that was. In any case I’d recommend giving the ‘EOS recommended solutions’ a go, that’s what I use (envy control to be precise):
Be sure to also consult the ArchWiki on the Optimus as well:

The laptop itself has just got one output, but I use a docking station with two outputs. HDMI and Display port.
Thanks for the links, I’ll give that a try.
Unfortunately I just got greeted by a blinking cursor in the upper right corner after stepping out for a moment, had to do a REISUB and now I seem to have lost Bluetooth (Mouse+Keyboard) and who knows what else :frowning:

1 Like

Ah, I see. Sound’s a lot like you’re one of the edge cases that might benefit from sticking to X11 for a while longer (opinions may vary), especially if you don’t have a specific reason for Wayland and have a perfectly working setup for X11.

I think I am about to reach the same conclusion :slight_smile:
I am unable to work with this setup.

I read that people are able to select if they want to use X11 or Wayland when logging on, I don’t get this option because I supply my password when the machine boots and then go straight into my Plasma session. Hence I need to find out where I can default to X11 again…


That should do the trick

…it did :slight_smile:

Back to two monitors now, not even a reboot required.
Bluetooth is still broken though…I guess that will need a reboot.

Thanks for helping along

1 Like

I recently sold it, but had an XPS 15 using a Dell dock and two external displays. I finished building a new computer about 2 weeks ago, so never got to experience Plasma 6 with it. But similar to @TheRaOct it was pretty plug ‘n’ play for me as well.

Your bluetooth issue seems to be somewhat common at the mo’. I’m having it as well on Plasma 6 every time my computer sleeps. The only things that works is either a hard reboot or systemctl restart bluetooth.service. And that’s a right pain since I have a BT keyboard. :person_facepalming:t5:

1 Like