Dual Monitor Black Screen: Wayland, and Radeon

Hello anyone :smile:

I’ve been pouring through posts here on the forum and elsewhere, but can’t land on a solution.

My second monitor usually works but lately not at all. It is connected, does have a signal, I can see backlight, can move mouse curser and drag windows to the second screen, but is black screen. I have booted with and without the HDMI connected, have tried lts kernel both ways, and various attempts from previous posts but I got nothing!

Autorandr shows me Detected Wayland session 'Wayland-0' Exiting

Most recent;y I took a stab at wdisplays but it shows the error Compositor doesn't support wlr-output-management-unstable-v1.

More information:

xrandr --listmonitors
Monitors: 2
 0: +*eDP-1 1920/340x1080/190+0+0  eDP-1
 1: +HDMI-1 1920/480x1080/270+1920+0  HDMI-1
xrandr
Screen 0: minimum 16 x 16, current 3840 x 1080, maximum 32767 x 32767
HDMI-1 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 480mm x 270mm
   1920x1080     59.96*+
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1680x1050     59.95  
   1440x900      59.89  
   1280x800      59.81  
   1152x720      59.97  
   960x600       59.63  
   928x580       59.88  
   800x500       59.50  
   768x480       59.90  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1600x900      59.95  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080    239.88*+
   1440x1080    239.87  
   1400x1050    239.76  
   1280x1024    239.78  
   1280x960     239.80  
   1152x864     239.87  
   1024x768     239.74  
   800x600      239.81  
   640x480      239.72  
   320x240      238.24  
   1680x1050    239.81  
   1440x900     239.80  
   1280x800     239.70  
   1152x720     239.91  
   960x600      239.72  
   928x580      239.78  
   800x500      239.72  
   768x480      239.72  
   720x480      239.35  
   640x400      239.49  
   320x200      238.84  
   1600x900     239.83  
   1368x768     239.74  
   1280x720     239.96  
   1024x576     239.43  
   864x486      239.60  
   720x400      239.62  
   640x350      239.59

I’m not sure where to go from here and appreciate any help!

It might be helpful to give your full hardware output. You can post the link.

inxi -Faz | eos-sendlog

Thanks for that reminder :laughing:

https://0x0.st/HR62.txt

Have you checked for a new UEFI Bios update. Not sure what the exact model this laptop is but it looks like there is an update for 2023 if i have it right. It might not hurt to update it if there is a new Bios update. Not sure it will fix this issue but is important for Ryzen processors.

Edit: Is it the Delta 15 A5EFK

Edit: Check if this is correct.

Edit: I see your current version is E15CKAMS.105 date: 10/28/2021

All correct, its the Delta 15 A5EFK-001 and I was able to update the Bios. Strange thing though is before I did that, the second monitor worked all of a sudden! I flashed the bios anyway, waiting to see what happens when I move the laptop away from my desk and back again to the second screen.

Updated inxi -Faz | eos-sendlog here: https://dpaste.com/FZ83J3GZ3

1 Like

Thought we had it sorted out but my luck ran out :rofl:

Updated the bios and things were just fine, now it’s back to the behavior of post 1. Worked well for about 4 days though, but also noticed when I plug in the HDMI the dash to dock starts jumping up and down. Weird.

Does your monitor only have HDMI or does it also have DP?

It does have DP. Oddly enough it’s working again. Another clue lol… it’s a very inconsistent problem it seems.