Dual boot with LMDE 6 - os-prober not working?

Trying something different. On this NUC PC I usually switch distros often to try and learn new things. I decided to try dual booting for fun and booted the EOS Galileo install ISO.

Before I started the installer, I use KDE Disk partitioner to shrink my BTRFS partition used by LMDE 6 so I’d have enough room for EOS.

I then started the installer. None of the options showed the option for using the unused space. They may have meant that, but I didn’t want to risk it. So I used manual partitioning.

I just setup the unused space as a BTRFS partition mounted at / and on my original ESP I set it to mount at /boot/efi and it set the flags for boot and grub. Also didn’t format the ESP, just use it.

My install of a No Desktop version went correctly and I can boot it but grub shows no LMDE6. So I uncommented the OS-Prober disable option in /etc/defautl/grub and ran
sudo grub-mkconfig -o /boot/grub/grub.cfg

When I reboot, still no LMDE option

It’s using the new partition for EOS, so I know LMDE is still there.

What step did I miss?

Have you made the changes to this line?
Make sure to remove the ‘#’ as well in front of the line.


in /etc/default/grub

Just an update. I can use the PC BIOS Boot override option, F11, and select Debian and LMDE 6 will boot. I tried doing the same OS-Prober stuff but when I boot without interference I still get EOS with out an menu option for LMDE

yes and I ran grub-mkconfig -o /boot/grub/grub.cfg

1 Like

Okay, I faintly remember an inability of os-prober detecting btrfs systems. For now I can just use the BIOS settings to manage which EFIbootmgr entry is default and use the manual override F11 to do my booting. The last time I did a multi- boot I did it with all the OSs being in different pairs of subvolumes and just edited the kernel boot cmd. Way too complicated.

I interpreted your op as if you wanted to solve the problem of non working os-prober on multiboot systems on Btrfs and having a boot menu entry on the Grub’s boot menu. Manjaro’s os-prober solves that specific issue.

Anyways, your system your choice.

1 Like

Thanks for your help. Since this is mainly for testing, I didn’t want to spend a lot of time on a more permanent fix that was this complicated. I’m just trying to have some real hardware where I can boot into EOS and start testing Hyprland which added on top of EOS nicely.

In fact what I did was go back and reinstall EOS KDE with just EXT4 instead of BTRFS to avoid all this. Now I can update grub on my LMDE6 to put EOS in it’s menu so I can quickly switch between the 2. I can also at EOS login choose between Plasma and Hyprland.

I really like Hyprland, but it takes a lot of work to get it like I want it. Plasma tiling may end up making a better system.

1 Like