Dual-boot Win11 + EOS

Filesystem

I bought this SSD.
Specs say:

  • Up to 2,100MB/s Read
  • 1,700MB/s Write

I was wondering should I stick to good old ext4 or is there a faster filesystem available?

As far I understand Btrfs just gives some extra features not speed improvements.

Dual-boot

So the plan is to install windows first and EOS after.

Basically you can use only one EFI partition for all systems, provided it has enough space for the files.

Will windows create big enough efi partion?

I think I will give 150GB for windows and 70GB for EOS. After that I will install according these steps (except in efi I will select windows created efi partion)


PS I’m actually want to leave about 100GB for 3rd OS which will be another EOS but probably with Btrfs to play around and main EOS with ext4.
The question is will efi partion have enough space for all 3 OS?

Tricky question, but there are alternatives, depending on what are your goals.
I’m not sure if you can make a bigger EFI partition while installing windows, but if that is possible, then try that.

As far as I know, it is not mandatory to put all *.efi files in the same EFI partition. But then booting may require some (small) extra manual work.

One alternative, if possible for your purposes, is to install Windows in a virtual machine, e.g. with VirtualBox. But if you want to play heavy Windows games, then this is likely not an option.

About filesystems, ext4 is probably the most reliable option. But is lacks some features that btrfs has, so this too depends on your preferences. And btrfs has some major changes ahead, which may cause issues later.
See more at https://www.phoronix.com.

If I were me, I would use ext4.

We will see. I have no idea how big it makes the efi.

I am making multi-boot USB with Ventoy (gui package from aur). I guess I need use gpt as partition schema and check secure boot for Windows, correct?

If you install Windows first you have the option of setting the amount of the drive to use for Windows when you install it. This will leave you with unallocated space after the Windows installation which you can then use for EOS. After installing Windows if you leave unallocated space you can actually activate it in Windows and just don’t set a drive label to it under disk management. It doesnt matter that it is NTFS because the installer will format it later to whatever file system you choose.

If you install Windows using the whole partition then you have to shrink that partition in order to create space to install EOS. What i don’t like about doing it that way is the it puts the other partitions that Windows creates behind the space that you shrink to install EOS. The other way keeps all the Windows partitions together and separate from the left over un-allocated space that you use to create a partition to install EOS.

Edit: This is how i have mine installed. Eos is the last partition behind all Windows partitions.

Edit2: Of course i may be too late with this advice if you already have Windows installed.

I assume about 500 MB EFI partition is (maybe more than) enough for Windows and 2 linux systems.
Please someone correct me if I’m wrong.

You can make the efi partition larger in Windows when installing. If you need instructions?

https://itectec.com/superuser/create-efi-partition-before-installing-windows-10/

Edit: There are a number of different ways to resize the efi partition before install.

This has been a point of interest for me too. I am expecting my new work laptop any day now (Surface Laptop 4) and I need to keep Windows on it but I would like to have ESO installed as a second OS.

Now in the past, I have done Pop_OS alongside of Windows, but I havent tried EOS. Will the EOS installer assist with setting up the partitions and bootloader?

Yes i forgot about install alongside as it wasn’t there before. I’m not sure how it works with windows but i would assume it would be the same as if installing alongside another Linux where it shrinks the partition but i haven’t tried it with Windows. Not sure if it shrinks the volume C: like windows does and leaves those extra windows partitions behind the shrinkage? Or whether it shrinks the whole partition? That’s why i mentioned it to @Elnath because you have the option to do that if you are installing Windows fresh.

Wouldn’t this just wipe out the whole disk and take Windows away with it?
I think you would need to make a GUID partition table on the whole disk before installing Windows and so on… Or am I reading your post wrongly?

Maybe I’m mistaken and you could be right? I think what you have to do is use Windows to activate that unallocated space without a drive letter is what i did and it formats it NTFS. Then i installed EOS and let the installer do it’s thing.

You could just leave it unallocated and operate on it from the live iso. No need for activation or formatting etc. from Windows.

On a second thought, you don’t even need to make a GPT prior to installing Windows.
Its installer will take care of it. I think you would just need to point it to a chunk of unallocated space on the disk and that’s it.

I edited my post and took that out. I think if you leave it unallocated for some reason it doesn’t show up but i can’t remember exactly what happened as i don’t do this everyday but i have just done it recently on this laptop to do a fresh install of Windows 11. Now that you bring it up i think you are right it will wipe out the whole drive after installing Windows so that is why i activated it in Windows and then let the installer do it’s thing. Formatting it from NTFS to Ext4 is no issue for EOS install.

Also you are right the installer does create GPT partition for Windows install.

Edit: I just wanted the partition to be outside of the C: volume so it’s separate and not in the middle of Windows partitions which usually are 4 in total.

2 Likes

I have nothing installed yet.

Right now its like 1 problem solve, 2 new problems arise.

Ventoy problem

I am trying now Ventoy.
I did install GUI with yay ventoy-bin.
After installing ventoy on my usb, I just copied EOS iso (endeavouros-2021.08.27-x86_64.iso).

On boot Ventoy listed EOS, but trying to launch it gave me error:

No bootfile found for UEFI!
Maybe the image does not support x64 UEFI

I have no idea what is the issue

  • BIOS settings?
  • EOS .iso?
  • Steps I did with Ventoy?

Mounting problem

Alright unplug from PC (where I want to install stuff), plug back to laptop now I don’t see my USB in dolphin, but in terminal it shows:

[juris@juris-aspiree1571 ~]$ lsusb
Bus 002 Device 005: ID 0951:16a3 Kingston Technology DT microDuo 3.0

Why it doesn’t show in Dolphin? When I plugged in Dolphin I could always mount it from there.

How can I mount it with terminal, what are the steps?

I personally wouldn’t use ventoy. What are you using currently on the desktop?

Edit:

On Eos i use popsicle-git to create live ISO

What are you using currently on the desktop?

Are you asking what I used previously to make bootable USB?

No…i was wondering what desktop to see what program to use for creating a live ISO.

I have Plasma DE.

Is it EndeavourOS?