Dual Boot Issue: EndeavourOS Grub Not Appearing in Boot Priority After Installation

Hi everyone,

I’ve recently installed EndeavourOS as a dual boot alongside Windows 11 on my Acer laptop. The installation process seemed to go smoothly, but upon rebooting, my system goes straight to the Windows Boot Manager. I’ve checked the BIOS, and I can’t seem to find EndeavourOS in the boot priority order.

I’ve already attempted to repair Grub on a UEFI system, but Grub still doesn’t show up.

Here are some logs from my laptop:

  1. Hardware information: http://ix.io/4GDE
  2. Installation log: http://ix.io/4GDI
  3. Efibootmgr: http://ix.io/4GDJ
  4. Parted -l: http://ix.io/4GDK
  5. lsblk: http://ix.io/4GDM

I would greatly appreciate any help or suggestions. Thank you!

Are you sure you didn’t install EndeavourOS in Legacy/BIOS mode?

If you don’t boot the ISO in UEFI mode, it won’t install that way either.

I’m sure I install EndeavourOS in UEFI mode

Check your BIOS settings to confirm the SATA controller is set to AHCI mode.

It looks like there are two EFI partitions, one on sda and another which has been named “EFI System Partition” on nvme0n1. Although EOS is installed on the nvme drive, it looks like you have installed Grub on the sda disk (at least from the chroot). Was that intentional?

you right, it was my mistake to install grub on sda. but after installed grub on nvme, the grub is still not visible in BIOS

fortunately I found this guide and add the grub from nvme -> endeavourOS -> grub64.efi. now when booting with F12 to grub menu, I can find my EOS grub

But this is still not correct if you don’t set the boot order to boot from the drive that has the grub menu. It should have an entry in the boot order to set it to boot from grub and it will say either endeavouros or grub or whatever depending on how it’s installed and named or from reinstalling grub. You shouldn’t have to use an Fkey in order to boot to grub although you can. Did you run the grub update command when you installed it to the proper drive?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.