Drives want to automount on login

I am having an issue with my 2 windows NTFS drives.
When I login to my EOS (KDE) install both of the NTFS partitions prompt me for a password in order to mount them. I would like to get rid of these prompts because they are annoying and I don’t want to have these two drives mounted at all.

I have tried removing everything everything about these two in /etc/fstab but that didn’t work then i also tried disabling auto-mount with gnome-disk-utility but that also didn’t do anything.

Screenshot_20220403_230609

❯ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=0677-BCB1                            /boot/efi      vfat    umask=0077 0 2
UUID=a873d99a-243b-4cd2-ac9e-fba9ac6e0b93 /              btrfs   subvol=/@,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
UUID=a873d99a-243b-4cd2-ac9e-fba9ac6e0b93 /home          btrfs   subvol=/@home,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
UUID=a873d99a-243b-4cd2-ac9e-fba9ac6e0b93 /var/cache     btrfs   subvol=/@cache,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
UUID=a873d99a-243b-4cd2-ac9e-fba9ac6e0b93 /var/log       btrfs   subvol=/@log,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
/dev/disk/by-uuid/29a6ed6e-40d5-4ef1-aa7d-c7f5892c2951 /mnt/2tb auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=2tb 0 0
/dev/disk/by-id/usb-VendorCo_ProductCode_0447471147536777854-0:0-part1 /mnt/usb-home auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/7CA9A253334F2A92 /mnt/7CA9A253334F2A92 auto nosuid,nodev,nofail,x-gvfs-show,noauto 0 0
/dev/disk/by-uuid/2E96704696701097 /mnt/2E96704696701097 auto nosuid,nodev,nofail,noauto,x-gvfs-show 0 0

The issue was the “removable devices” program that kde uses it was set to mount all drives at login.

Hello @pogo welcome to the forum.
You are off to a good start finding your own solution.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.